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Part 1: Introduction
1. About this manual & 2. List of abbreviations

Part 1: Introduction

Olink high-multiplex immunoassay panels provide an efficient and innovative tool for targeted human protein biomarker
discovery, development and validation.

1. About this manual

This user manual provides you with the instructions needed for data processing when running Olink® Explore HT with a
locally installed set up of software.

NOTE: The information in the Olink® NPX Explore HT User Manual is believed to be accurate. However, the
displayed screenshots may differ from actual user interface and should be considered as examples.

1.1 Intended use
Olink NPX Explore HT is a data analysis software that is designed for the Olink Explore HT platform. It allows for importing
data, validating data quality, and normalizing Olink data for subsequent statistical analysis.

Olink NPX Explore HT is intended for research use only. Not for use in diagnostic procedures. All trademarks and
copyrights contained in this material are the property of Olink® Proteomics AB unless otherwise stated. For questions,
guidance, and support, contact Olink Support at support@olink.com.

1.2 Intended target group
Olink NPX Explore HT is intended to be used by staff certified to run the Olink Explore HT platform. Quality control should
be performed by trained users that determine whether data from a run can be approved for further analysis.

2. List of abbreviations

%CV Coefficient of Variance

NGS Next Generation Sequencing
PCR Polymerase Chain Reaction
PEA Proximity Extension Assay
QC Quality Control

SD Standard Deviation
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3. Associated documentation & 4. Technical support

3. Associated documentation

3.2.1 Olink documentation

Olink documentation

Olink® Explore Preprocessing Technical information, v4.0

Olink® Explore CLI Technical information, v.2.0

Olink® Explore HT User Manual

Olink® Explore Sequencing using NextSeq 550 User Manual
Olink® Explore Sequencing using NextSeq 2000 User Manual
Olink® Explore Sequencing using NovaSeq 6000 User Manual
Olink® Explore Sequencing using NovaSeq 6000 S4 User Manual

All relevant Olink documentation is available from the Olink website www.olink.com/downloads.

3.2.2 Other documentation

Article & lot configuration sheet - delivered together with the analysis kit.

4. Technical support

For questions, guidance and support, contact Olink Proteomics at support@olink.com.
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5. Process

5. Process

5.1 Hardware and software requirements

511 System requirements for Olink® Explore HT

Components Minimum Recommended
Operating System Windows® 10 or higher

Processor Intel® Core™ i5 Intel® Core™ i7 or higher
Memory 8 GB RAM 16 GB RAM or more
Disk Space 500 GB 500 GB

5.1.2 Requirements for analysis
Files and information needed for analysis:
» Count files in CSV format and run metadata in JSON format (NGS raw data pre-processed using ngs2counts)

» Plate layout with sample names

« Data analysis reference ID number of reagents used (provided on the Lot configuration insert delivered with the kit)

5.2 Pre-processing runs

Preprocessing is a necessary step in all Olink® Explore analyses. During preprocessing, the Next Generation Sequencing
(NGS) output from the sequencing instrument is converted to counts files containing the number of reads for each Olink®
sequence and a run metadata file containing additional information which is necessary for importing the counts files into
the analysis software Olink® NPX Explore HT, or Olink Explore CLI.

For more information, refer to Olink® Explore Preprocessing Technical information and Olink® Explore CLI Technical
information.

53 CLI

QC and normalization of Olink Explore HT data can be performed either using the Olink NPX Explore HT software or using
the Olink Explore CLI software or using a combination of the two.

R }
NGSa;Vata :) ) | Pre-processing | ——p Counts —) | NPXExplore HT | = Extended NPX file
—} Analysis Report
Explore
(Calculation Module|
Plate Layout _’
files l T

!

ExplorecLl | =P Explore
+— project
»
alculation Module

Output data

Olink® Explore CLI is a command-line interface (cli) for the Olink® Explore HT product. The application is capable of
performing normalization, quality control (QC) and CV computations on NGS data and exporting the results on several
supported formats. For more information, refer to the Olink® Explore CLI Technical Information.
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Part 2: User Interface

6. General

The Olink® NPX Explore HT user interface consists of several views on separate tabs where information and results are
displayed. These views are described in this chapter.

6.1 Search

Use Ctrl + F to open a search field. The search function works on most views for either plain text or sample names, assay
names or Uniprot IDs. The first match found will be highlighted. The search function is also available from Edit > File.

Search for: Ia550

|
icam:‘

6.2 Help
Press F1 to open the Olink® NPX Explore HT User Manual as a PDF file. The manual can also be downloaded from
www.olink.com/downloads.

6.3 Treeview

The tree view displays the plates and the imported data for each plate.

a Mew_Project™

[Fie | Edit Project View Help

- 20200279-003
- Block 1
- Block 2
.. Block 3
- Block 4
- Block 5
- Block &
- Block 7
- Block 8
=- 20200279-004
- Block 1
- Block 2
- Block 3
- Block 4
- Block 3
- Block &
.. Block 7
- Block 8
. 20200279-005

¢ Click on the + next to the Plate name to display the imported data for each plate.

e Mark an individual block to see information about that specific block. If a plate is highlighted in the Tree View,
information for the first block is displayed on the specific tabs.

¢ Right-click on a block to recalculate, delete, include or exclude a block.

NOTE: If there is panel plates with missing data, a window will be prompted. Contact support@olink.com
for support.
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6.4 Selection information

The Selection Information view in the lower left corner displays information about the currently selected item in the Tree

view.

Selection Information

# Block Block 1

# Samples 63

# Experiment name  LJ129-3042-re...
# Index plate A

#Inclusion status  Included

# Version status Up to date

Item Description

# Block Selected block.

# Samples Number of samples, excluding control samples, in selected Olink panel or run.
#Experiment name Experiment specific name.

# Index plate Panel specific index plate.

# Inclusion status Shows included or excluded status of the panel.

# Version status Shows if the version is up to date or outdated.
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/. Tabs

7.1  Project

The Project tab contains fields for entering and saving project information.

9 New Project” - o x
File FEdit Project View Help
= 55112233_SP100001 Project Plate Layouts Runlog Quality Control Summary Supplementary Tables Correlation Assays Plate Variation PlateData CVTable Heatmap Sample OC Overview  Sample C| ¢ | *
Block 1
Block 2 ProjectName:  [New_Project |
Block3 .
Block 4 Sample Matrix: | |
Block 5 _
oct Comments for Project:

Block
Block 7 Comment Date [user
Block 2
5 §5112233_SP200002
Block 1
Block 2
Block 3
Block 4
Block 5
Block§
Block 7
Block?

Selection Information

= Block Block 1
= Samples 6
ent name  LI126-3042-re...

‘ p—

0/300
Data Analysis Reference ID

Block 1 Block 2 Block 3 Block4
D10001 D20001 D30001 D40001

Block 5 Block 6 Block 7 Block8 - : B
D50001 D60001 D70001 D80001 ‘ ' I I I

Normalization: Plate Control 2

71.1  Project Name
The project name is displayed in the NPX data output file and the Analysis Report.

7.1.2  Sample Matrix
This field is used to describe the sample matrix, e.g. “Plasma” or “Serum”. The information is displayed in the Analysis
Report.

7.1.3  Comments for Project
Write a message in the box next to the Comment button. Click the Comment button to add the message in the Comments
for Project field. The comments will only be visible in the project tab and not be generated into the Analysis Report.

Copy a comment by right-clicking on the comment and selecting Copy.

7.1.4 Data Analysis Reference ID

This field displays data analysis reference ID for the blocks included in the project.
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7.2 Plate Layouts

General:
The Plate Layouts tab shows the sample plate setup for the selected run, and general information about the run.

Each sample position is automatically annotated to one of the following content types, based on the sample naming:
¢ White: SAMPLE

e Red: PLATE_CONTROL

e Blue: NEGATIVE_CONTROL
e Yellow: SAMPLE_CONTROL
e Darkgrey: EMPTY

e Light grey: NOT_USED

Neither EMPTY or NOT_USED wells are covered by the NPX calculations. EMPTY shows counts while NOT_USED shows
nothing.

¥ Olink NPX Explore HT (internal) : New_Project™ - o X
File Edt Project
-20200279-004.¢ Project PlateLayouts Runlog Quality Control Summary ~Supplementary Tables Correlation Assays Plate Variation Plate Data CV Table Heatmap Sample QC Overview Sample Control Variation * | *
Block 1 ~
Block2
focks Plate: 20200279-004_ht
Block4
Blocks. 1 2 3 4 5 6 7 8 9 10 11 12
Blockd 24 234 a4 54 54 r r o4 ses 455 Reft [ sapLe
Block? A ] PLATE_CONTROL
Blocks savpLe
- SAMPLE  SAMPLE  SAMPLE  SAMPLE  SAWPLE  SAWPLE  SAMPLE  SAMPLE  SAMPLE  sawrLe  ONTROL [l NEGATIVE_CONTROL
e 624 B34 844 554 554 En e e B4 Bs A2 5] saMPLE_CONTROL
B SAMPLE C
NOT USED |SAMPLE  SAMPLE  SAWPLE  SAMPLE  SAMPLE  SAMPLE  SAWPLE  SAWPLE  SAWPLE  SAWPLE  ONTROL | []NOT_USED
it 24 =" ot 54 ot o4 a4 o4 cos ons Rai3
sawpLe ¢
SAVPLE  SANPLE  SANPLE  SANPLE  SAWPLE  SAWPLE  SAVPLE  SAMPLE  SAPLE  SAWPLE  SAWPLE  OMTROL
D14 024 034 et 054 054 o74 N 054 oos ois
SAMPLE SAMPLE  SAMPLE  SAWPLE  SAWPLE  SAMPLE  SAMPLE  SAWPLE  SAWPLE  SAWPLE  SAWPLE
et 24 = et 54 En En En En e0s Ens
E
SANPLE SAWPLE  SAWPLE  SAVPLE  SAWPLE  SAWPLE  SAWPLE  SAWPLE  SAWPLE  SAWPLE  SAWRLE
Fia F24 Fa4 Fas Fs4 Fos 4 N F34 Flo4 Fia
=
SAVPLE  SANPLE  SANPLE  SAWPLE  SAWPLE  SAWPLE  SAWPLE  SANPLE  SAPLE  SAWPLE  SAWPLE
G14 24 634 s G54 o4 G4 = G4 s
G
SAVPLE  SAMPLE  SAMPLE  SAMPLE  SAWPLE  SAWPLE  SAVPLE  SAWPLE  SAMPLE  SAMPLE
His 24 = et = e o ot ot res
Selection Information
o o e . w e e e o
= Plat ayout flename. 20200279-004 i SAMPLE SAWPLE  SAWPLE  SAVPLE  SAMPLE  SAMPLE  SAWPLE  SAWPLE  SAWPLE  SAWRLE

Useful for:

¢ Getting an overview of the plate setup, one block at the time.

Functions:
¢ Choose block to display in the tree view.

¢ Information about the plate is shown below the plate layout.

10
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73 RunlLog

General:

The Run Log tab shows a detailed list of all run units at either plate or block level. Each run has a comment window where
users to make notes in.

¥ Olink NPX Explore HT: New_Project” - o x
File Project  View Help
=5+ 20200279-004_ht Project PlateLayouts Runlog Quality Control Summary  Supplementary Tables Correlation Assays Plate Varistion PlateData CV Table Heatmap Sample C Overview Samp 4| * |
Block 1
oct Plate: 20200279-004_ht a
Block2
Block3
ok Submit all
Block 5
Block 6 ‘Sequencing date: 20230405 Fowcel ID: [HYMWNDSKE | o [ —
Block7 55 plate name: [20200279-004_ht | Fowceltype: [54 ]| ot Commert
Blocks larual <
Runname: [LI123:3042rep1 | Foncelside: [a I s
timary cause: v
[Bock 1 ] Ubrary:[1 ]
Stepfaled: Not appicable v
T — o e
Index plte: | SIS nclusion satus: Included ~
Instrumert 1D [A00915 Plte Cortrol: [+
o] p— Sam || s
Cartie [sout 20250405 AMYWINDRS Nogatve Core
Sequencing date:[2023-04.05 Rowcel ID: [HYMWNDSXS | [ Commert.
55 plate name: [20200279-004_ht ] Foweeltype: [s2 ]| e e Commert tesi
Runname: [LI1233042rep1 | Fowcelside: [ | o
imary cause: v
[Bock2 ] orary:[1 ]
e
Ot i e D
Selection Information Rennnesded: @ No O Yes
Index plate: [Sample 196
#Plate layout filename  20200279-004) Included e
Fmer D [R0515 Ple Cores L (St | [t |
Countfe: [counts_2023-04-05_AHYMWNDSX3_L| Negative Control
Sequencing dete (20250405 ] Fomeeti0: | T ‘ ] comen
S5 plate name: [20200273-004_ht ] Fowceltype: [54 | . e ]
anual v
Run name: LJ128:3042rep1 ] Fowcelside: [ I
imary cause: <
[Bock 3 | worany:[1 ]
Stepfaied, <
S B— o }
< 5| < >

Normalization: Plate Control .:

Useful for:
¢ Making comments on run unit level for others working on the same project.

¢ Getting an overview of run unit details.

Functions:
e Write a comment in the comment window for a run. Click Submit to save the comment or Reset to remove it.
e Add arerun and edit its information.
¢ To submit comments and/or changes in more than one run unit, click Submit all, found above the list.
¢ Foreach plate, the following information is displayed:
— Sequencing date
— Sample source (SS) plate name
— Runname
— Data analysis Ref ID
— Index plate
— Instrument ID
— Count file
— Flowcell information: ID, type and side
— Library
— Plate control and negative control yes/no
¢ Editable information:
— Rerun of
— Manual assessment
— Primary cause
— Step failed
— Rerun needed no/yes

— Inclusion status and reason

11
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74  Quality Control Summary

General:

The Quality Control Summary tab displays a summary of the QC criteria per block. Refer to 14. Overview for description of
the QC criteria.

@ Olink NPX Explore HT nterma): New Project o

[FiE] ot Proect View Help
57.20200279-003 Project Plate Layouts Runlog Quality Tables Plate Varistion Plate Dats CVTable Heatmap Sample QC Overview Sample Control Varistion Audit Log

Block 1

Block2 Plate: 20200279-003

soars

Block4 Plate ID Panel  Block Failed samples FailedPC  Failed NC  Failed Sample Control Warned assays BlockQC  Systematic effects Counts  %Passed

glcks b il ol o Pl oo o e |

Bockd womas a2 om oo o oo s o s o

Bock? W w3 om o e o ores mss woe e 10004

— womas i om woows oot ML Coumnetet s 00w

Soorr womas s om woom o b WU G serso oo

Hoar2 W o om noowm o 5 W o e o0

o womas a7 om woos s wl o e 0%

Hocks womas s om woowm s w o s 00w

iocks

o

o

Block 8

a0

Useful for:
¢ Reviewing failed blocks/samples.
¢ Finding systematic effects.

Functions:
¢ For each plate, the following information is displayed:
— PlateID
— Panel
— Block
— Failed samples
— Failed PC
— Failed NC
— Failed Sample control
— Warned assays
— Block QC
— Systematic effects
— Counts
— % Passed

12
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75 Supplementary Tables

General:

The supplementary Tables tab contains five tables displaying samples that have failed or have warnings based on QC
criteria. All data for one sample source plate is displayed at a time.

Only tables that contain data will be displayed.

Useful for:
e Reviewing flags of all samples and assays in tables, divided into five different flag reasons:
— Assay warnings
— Samples with low total counts
— Samples with low internal control count
— Deviating plate controls
— Failed negative controls
Functions:

e The following information will be displayed in the different tables:

Assay warnings Samples with low Samples with low Deviating Plate Failed Negative

total couns internal control count  Controls Controls
e Plate ID * Plate ID e Plate ID * Plate ID ¢ PlateID
e Panel * Panel * Panel * Panel ¢ Panel
e Block * Block e Block e Block ¢ Block
Assay o Well ID * Well ID e Well ID e Well ID
Olink ID » Sample ID e Sample ID e Sample ID e Sample ID
» Sample type ¢ Sample type * Amp ¢ Sample Type
 Total count ¢ Amp count e Ext
e Ext count e Inc
¢ Inc count

The Failed Negative Controls table includes empty wells that show too high signal.

To export the information, mark whole or parts of the table, right-click and choose Copy. Open preferred program, and

paste the information.

13



7.6 Correlation Assays

General:

The Correlation Assays tab shows correlation assays that overlaps across the blocks per sample plate.

¢ Aplateis chosen: all included run units are shown.

Part 2: User Interface
7. Tabs

¢ Anexcluded run unit is chosen: the text "No data display" is shown.

¢ Failed samples: no data points will be shown.
» Failed blocks: an empty graph with red text "Block QC failed [NPX] "will be shown.

Correlation assays are GBP1 (uniprot P32455) and MAP2K1 (uniprot Q02750).

Selection Information
#Plte layout fienome 20200279-003.cov
= Panels B

Useful for:

¢ Getting an overview of correlation assays.

Functions:

- 5 x

Prject Pste Layouts RunLog  Qualty ontrl Summay. Supplementay bl Corretion esays  PlteVaiation Pt Dsta CV bl Hestmap. Sample OC Overvie SampleContolVarstion Audt Log
Plate: 20200279-003
sssey [Gap1 v
Concationfor sy GOP1

25 25

2; 2 N

15 s
IR R c |- < AN A N A A P
~ o . ot - w o PO R
x bt —— < L
| —— : . 3 ] .
Tos. * B * s + o5

s

s 15

2 2

STRE B am U5 am G an 93 o 8 6m 05 s 1 s 15 B I I M It

Block 3 [NPX] Block 4 [NPX]

25

B .

15 .

, .
Sos . . - i
e\ T ., .

P P .

L. © e : T
] . : s |- .
@as .

15

2

B P T A I T

Block 3 [NPX]

¢ Use the Assay drop-down list to switch between correlation assays.

e« Zoom in and out with scroll wheel or touch pad.

14
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/.7  Plate Variation

General:

The Plate Variation tab displays a box plot with NPX values from the Sample wells. Failed run units will be left empty, refer
to the left run in the picture below.

Assay: All

NPX

= e
& &

Useful for:
¢ Detecting systematic variance in total intensity between plates.

Functions:

¢ Use the Assay drop-down list to show specific assay.

e Select All in the Assay drop-down list to view the summary of all assays for each sample.
¢ To highlight a plate, press ctrl+f or go to edit -> find and type in part of a plate name.

It is not possible to toggle between the normalization types. To change the type, go to Project -> Normalization and
choose type.

15
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7. Tabs

7.8 Plate Data

General:
The Plate Data tab shows heatmaps of one unit a time, including the internal controls: extension control, incubation
control and amplification control. Empty wells show counts but not NPX.

The heatmap displays deviations from the plate median for the selected assay using the colors blue and red:
¢ Blue: values below median
¢ Red: values above median.

Warnings are marked with flags in yellow and red:
¢ Yellow flag: indicates warning.
¢ Red flag: indicates fail.

¥ Olink NPX Explore HT (intema) : New_Project - o x
Edit  Project View Help
20200279-003 Project PlateLayouts RunLog Quality Control Summary Tables Correlation A Plate Dats  CyToble Hestmap Sample OC Ovenview  Sample Control Variation  Audit Log
Block 1
Block2 Plate: 20200279-003
Block3 Block 1
Block4
Block 5. Value Type
Block & O NPX @ Counts
Block7
Blockd
20200275-004
Block 1
B2 sy, [Btendonconiol 1] ymeatc et e [0 -
Block3
Blocka il 2] 5 4 5 6 7/ 8 9. d0f Ak 12
Block s
Slocke A 3807 3308 [EUIPM 3005 3352 2510 2537 250 2809
3 E SCSsCsC
Block 7
Block? B 2153 375 3757 3706 4038 2470 2720 2537 2281 3806
- 20200275-005

3931 2935 2296 3420 2564 3361 3075 .- 2549 . 3478
E E
L_RH
D | 3250 2444 3906 2187 2265 2504 2551 2670 2612
O 29625
W 6268
£ o454 332 370 3819 2960 3879 2181 2537
15 903 2553 2065 3454 3889 2858 JERE
3055 2373 3432 3162 2756 3409
PC  PC  PC
3351 2726 3411 2046 2861
NC

2707 3927

5919

‘Selection Information

#Block Block 1

Useful for:
¢ Inspecting counts and NPX across a plate for each assay.

¢ Discovering systematic patterns.
« Discovering plates swap based on data pattern across the plate (If the plate has any empty well).

Functions:
¢ Change values by selecting either NPX or Counts.
¢ Use the assay drop-down menu to change which assay to display.
* Use the Systematic effect filter to switch off or show either column or row effect.
e Hover over a well to show:
— Sample
- WellID
— Value

— Deviation from median

16
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79 CVTable

The CV Table tab shows the CV information, one row per block. CV is calculated based on the data points of Sample
Controls that passed the QC criteria.

& New proect - x

Fie eat [BERE] View Hep

20200275-003 Project Plte Layouts RunLog Quality C: I Plate Varaton Plte Data CVTsble | Heatmap Sample OC Overvew Szmple ControlVariston Audit Log

20200279-005

Selection Information

#Panel Type Blocks
#Samples El
#Flagged positions 95

# Experiment na

Normalization: Plate control

Useful for:
¢ Getting an overview of the CV values per block, and which blocks that have missing CV values.

Functions:
¢ Choose which panel to be shown in the tree menu.

¢ To export the information, mark whole or parts of the table, right-click and choose Copy. Go to preferred program, and
paste the information.

¢ Missing values for Intra CV mean and Inter CV mean are represented by NA.

17
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710 Heatmap
General:

The Heatmap tab contains a color-coded view for all assays and samples in the chosen block. The assays are displayed in
the horizontal direction and samples in vertical direction. Empty wells show counts but not NPX.

The heatmap displays deviations from the plate median for the selected assay using the colors blue and red:
¢ Blue: values below median
¢ Red: values above median.

& New Project - x
Fle Edt Poject View Help

20200279-003 Project Plate Layouts Runlog Quality Cc Plate Variation Plate Data CVTable Heatmap Sample QC Overview Sample Control Variation Audit Log.
Bock] Plate: 20200279-004

ssssss

ssssss

Slock 1 NP ® Counts
Block 2 Sort order: | Column v
‘‘‘‘‘‘ s S 0 et

20200275-005

TEST
Sample 87192
Included
Uptodate

Useful for:
¢ Finding systematic patterns.
¢ Finding outlier samples for specific assays.

Functions:
¢ Change values by selecting either NPX or Counts.

« Use the Display drop-down list to select the sample type to display (All samples, Sample, Plate Control, Negative
Control, Sample Control, or Empty).

e Hover over a well to show:
— Assay
— Sample ID
- WellID
— Deviation from assay median
- NPX
¢ Use the Sort order drop-down to sort either by row or by column.
¢ Use the Systematic effect filter to switch off or show either column or row effect.
e Zoom in and out with scroll wheel.
¢ Move the map to see different assays by clicking and holding the left mouse button and drag the heatmap.

18
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711 Sample QC Overview

General:

The Sample QC Overview displays a color-coded heatmap showing status for each sample in all blocks.

Blue: Pass
Red: Fail

Yel

low: QC warning

If a sample has both a fail and a warning, it is shown as fail.

8 Hew_project
Fle Eai Project View Help

20200279003
Block 1
Block2
Block 3
Block 4
Block 5
Block6
Block 7
Block8
20200279-004
Block 1
Block2
Block3
Block 4
Block 5
Block 6
Block7
Block8
20200279-005

Project Plate Layouts Runlog Quality Control Summary Correl
Plate: 20200279-003
[ [IETEE ] Warning
WelllD SamplelD Block1 Block2 Block3 Block4 BlockS Blocks  Block7  Blockg
AL A3
2 A3
A3 A33
A A3
A5 EWPTY
A6 EMPTY
AT AT
FUE)
K a3
A0 Ref13
AN Ref 123
A2 Ref 133
B B2
B2 23
B3 B33
B4 B43
BS  B53
85 863
87 B2
83 a3
B9 o2
B0 BI03
BIl B13
B2 B3
a a3
@ 3
a al
BTy
eIy
s ce3
a a3
a3
o ce3
co cs
oo
2 ocn3
LI 2K}

Useful for:

¢ Finding systematic errors across different blocks.
Functions:

Hover over the cells provides information on:

Sample ID
Block
Well ID

For failed and warned samples: reason for failure or warning.

PlateData CV Table

Well I Sample D

Al

A3

Heatmap Sample QC Overview | Audit Log

19
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712 Sample Control Variation

General:

The sample control variation view displays data for all Sample Controls in the entire project. Data points for both internal
control assays and regular protein assays are included.

NOTE: The range of the Y-axis differs between the blocks.

Prost Pyt oy oty Cotel Summary Soppemerty bl Coneton sy Pt Volen Pute Dt Y bl Hesima Sampe OC e, S4meContontn o

220275004

H~
}_F.g
I

s
1 -

i
Hi
1

Siocton rmtion
=ty e ST
.

Useful for:
¢ Getting an overview of the variation of the sample controls through blocks and plates.

Functions:
¢ Every row represents a block and every column a plate.

¢ Each boxplot represents non-failed Sample Control with NPX values.
¢ Excluded run units are not shown.

¢ Missing plate-block gives empty sub-boxplots.

20
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713 Audit Log

General:

The Audit Log tab displays all events for the current project.

File Edit Project \View

Help

20200279-003
Block 1
Block 2
Block 3
Block 4
Block 5
Block 6
Block 7
Block 8
20200279-004
Block 1
Block 2
Block 2
Block 4
Block 5
.. Block 6
.. Block 7
.. Block 8
20200279-005

Selection Information

#Block Block 1
#Samples &

#Index plate A
#Inclusion status  Included
# Version status Up to date

# Experiment name  1J129-3042-re...

Useful for:

W% Olink NPX Explore HT (intemal) : New_Project*

- o X
Quality Control Summary  Supplementary Tables Correlation Assays Plate Variction  Plate Data  CV Table Heatmap Sample QC Overview Sample Control Variation AuditLog |«
Working changes

Status Reason Time User

Unsaved change  Added the project comment ‘New comment' 2023-10-0308:..  OLINK\hann

Unsaved change  Updated the field SampleMatrix to "Manual 2023-10-02 0. OLINK\hann

Unsaved change  Updated the annotation for run unit c4477¢5f-c8c1-4729-088a-Sebdcch57799: Manual assessment: ‘Nene' -> ‘Pending’ 2023-10-03 0%t OLINK\hann

< >

History

Reason Time User A

Imported run for run unit 110df4a-T4ad-421-a34f- 30b76353386€ with Data Analysis Ref ID D2000T and plate layout 20200279-004 2023-09-27 14 OLINK\hanna,

Imported run for run unit 1aff0655-a2e6-d6df-adTe-cf5d558c 1260 with Data Analysis Ref ID D70001 and plate layout 20200273-004 2023-09-2714...  OLINK\hanna

Imported run for run unit 7a287215-e4c0-4dSk-bece-abf7fd2c36ed with Data Analysis Ref ID D60001 and plate layout 20200279-004  2023-09-27 14 OLINK\hanna...

Imported run for run unit 2385ed15-bbd0-4af2-Bbd7-fdbae74baTae with Data Analysis Ref 1D DS0001 and plate layout 20200279-004  2023-09-27 14:..  OLINK\hanna,

Imported run for run unit 452af319-70ad-42e4-288b-62775 debce with Data Analysis Ref |D D40001 and plate layout 20200279-004 2023-09-27 14.. OLINK\hanna,

Imported run for run unit 79fb0827-5877-4ade-8559-fb45F1fe7f8e with Data Analysis Ref ID D20001 and plate layout 20200279-004 2023-09-27 1 OLINK\hanna....

Imported run for run unit 7369db41-¢3¢9-43eb-bfa2-3247f94d3460 with Data Analysis Ref ID D20001 and plate layout 20200279-004  2023-09-27 14 OLINK\hanna...

Imported run for run unit 06fb3056-51ae-42cc-b47d-22551785c297 with Data Analysis Ref ID D10001 and plate layout 20200279004 2023-09-27 14:..  OLINK\hanna,

Imported run for run unit 15ee4681-f955-4da2-2683-0a32dch1320c with Data Analysis Ref ID D2001 and plate layout 20200279-002 OLINK\hanna....

Imported run for run unit 70223043-50f3-4592-a21 e-45b642dfdeB with Data Analysis Ref ID D70001 and plate layout 20200279-003 OLINK\hanna....

Imported run for run unit 8161d92e-671b-46db-bac2-b166{5835cfe with Data Analysis Ref 1D D60001 and plate layout 20200279-003  2023-09-27 14:..  OLINK\hanna,

Imported run for run unit 173f08a1-3cfd-4f23-a570-15630a23¢20f with Data Analysis Ref ID DS0001 and plate layout 20200279-003 2023-09-27 14 OLINK\hanna...

Imported run for run unit 5456a264-5c06-41ce-006f-b64a99736d77 with Data Analysis Ref ID D4000T and plate layout 20200273-003 2023-09-27 1 OLINK\hanna....

Imported run for run unit 3ec28276-Tde2-4c06-B19f-c58f8dS80T1 with Data Analysis Ref 1D D30001 and plate layout 20200279-003 2023-09-27 18... OLINK\hanna,

Imported run for run unit OcceacGc-2d4f-4c66-b 4234acd0 with Data Analysis Ref ID D20001 and plate layout 20200279-003 2023-09-27 14 OLINK\hanna... v

« Seeing what actions that has been done on the project.

Functions:

e The upper table shows changes not yet saved.

» The lower table shows changes that has been saved.
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Part 3: Quality Control
8. Introduction

Part 3: Operation

8. Introduction

Input data is counts files and metadata files generated by ngs2counts. For more information on pre-processing, refer to 5.2
Pre-processing runs.

This section describes how you analyze data step-by-step in Olink NPX Explore HT. The following steps are included in the
standard operating procedure:

Import run files (Plate layouts and NGS run folder) or open or clone a project.
Enter project information.

Perform quality controls including additional quality assessment.

Export data.

Create an Analysis Report.

S vk W e

Finalize the project

O New_Project™ - [u] x|
File Fdit Droject View Help
- 55112233 5P100001 Project PlateLayouts Runlog Quality Control Summary Supplementary Tables Correlation Assays Plate \ariation PlateData CVTable Heatmap Sample OC Overview Sample | < |*
| Block! ~
Block2
© ok Plate: 55112233_SP100001
Blockd
Elocks 1 2 3 4 5 & 7 8 9 10 11 12
:W:: SC Sgam ok 3 samied 3 snwkS 3 SCoampl okl 3 MMSSI3  KINE3 00N \issss  SGsC 3| [ISWPLE
i -Blod : X
: A |ShwpLe_c SAMPLE C sawpie ¢ L PLATE.CONTROL
i --Block8 ONTROL SAMPLE  SAMPLE  SAMPLE  ONTROL  SAMPLE  SAMPLE  SAMPLE  SAMPLE  SAMPLE  ONWROL NEGATIVE_CONTROL
- 55112233 5P200002 se50s 213 SDSOSeE M3 SCUNSST i3 YYSII3  DTGSSE LG Uvessss  SCSC23 SLTHIE FOIRTEL
@— Block] B |Sampie ¢ SAMPLE C SANPLE_C
~Block2 GNTROL SAMPLE  SAMPLE  SAMPLE  ONTROL  SAMPLE  SAMPLE  SAMPLE  SAMPLE  SAMPLE  ONIROL
Block3 5C sCH73 SAOF73  S52F73  S53CB3  SC.SBFCB SA33F  STEF03  S939C3  S897C3  SGSFC3  SC SCE284
Block4 s g ==y
SAMPLE C SAMPLE C SANPLE_C
Elocks ONTROL SAMPLE  SAMPLE  SAMPLE  ONTROL  SAMPLE  SAMPLE  SAMPLE  SAMPLE  SAMPLE  ONIROL
- Block POSFECS| saores  sears  s295°3 SRS BOSBIONS stoes  sicess  sames  sisen soi3 OISR
Block7 D Biate_co PLATE_CO PLATE_CO
Block® NTROL | SAMPLE  SAMPLE  SAMPLE  SAMPLE  NIROL | SAMPLE  SAMPLE  SAWPLE  SAMPLE  SAMPLE  NTROL
PG sdscEd sciTer  siTFR SITE3 seics  POSODSD. sy SIRZ3 SIDIG STy smET) RCERSSU
= puare co BLATE_CO PLATE_cO
NTROL | SAMPLE  SAMPLE  SAMPLE  SAMPLE  NEROLL | SAMPLE  SAMPLE  SAWPLE  SAMPLE  SAMPLE  NTROL
PCISTBIFS| stD2c3  SATICS  SDMDDS PC S445F5 SACDO3  SDISCE  SACHTI ec rEwts
' puateco PLATE_CO PLATE_CO
NTROL | SAMPLE  SAMPLE  SAMPLE NTROL | SAMPLE  SAMPLE  SAMPLE  SAMPLE NTROL
e iertion]kioomdion) PCISCHD sse1D3 S35FD8 535073 PC'SIBIFR 514051 S)D23 S10283  STDFE ook
#Block Block 1 G puateco PLATE_CO PLATE_CO
= Samples & NTROL | SAWPLE  SAMPLE  SAMPLE NTROL | SAMPLE  SAMPLE  SAMPLE  SAMPLE NTROL
* Experiment name LI129-1042-re.. PCSCB | sunss  saimcs 7801 POSOIB3S S1DE3)  SIESF3  S4SBF3 SO PCDFSLF
#lndex plate " H [Buate_co PLATE_CO PLATE_CO
k NTROL | SAMPLE  SAMPLE  SAMPLE NTROL | SAMPLE  SAMPLE  SAMPLE  SAMPLE NTROL
#Inclusion status  Included
@ #Vesionstatus Up to date
v
Plate Cortrol

®

Figure 1. NPX Explore main window with the Plate Layouts tab selected.

1 Information box displaying statistics about the currently selected item

Tree view showing Olink panels and blocks

Main work area
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Part 3: Operation
9. Start or open a project

9. Start or open a project

9.1 Import run files

To create a project, the following files must be imported:

¢ Plate layouts
¢ NGS run folder

1. Select File -> Import -> Import Plate Layouts - standard and browse to the preferred plate layout(s).
2. Select Project -> Select Data Analysis Reference IDs to verify that the correct panels has been selected.

3. Select File -> Import -> Import NGS Run Folder or File -> Import -> Import NGS Run Zip File, depending on the
format. Browse to the preferred folder or file.

4. Select plate layouts for both Index Plates and click Ok.

¥ import Ngs Runs - ] x

L1129-3042-repl

Instrument id:  AD0913 Instrument type:  NovaSeq 6000 Sequencing date:  4/5/2023
Flow cell id: HYMWNDSX3 Flow cell type: 54 Flow cell side: A
Library: Index Plate A: Index Plate B:

@1 [Not selected ~] Mot Selected -

20200279-003
0279 Block Data Analysis Ref ID Import Reason

A Mot Selected |1 HT_mini_poolnew_bei.. | [1  [v

A Block 2 HT_mini_poal_new_bi... O |«

A Block 3 HT_mini_poel_new_bci... O v

A Block 4 HT_mini_pool_new_bci... [

A Block 5 HT_mini_pool_new bei... | [ |+

A Block & HT mini_pool_new bei... | [ |+«

A Block 7 HT_mini_pool_new_bi... O |«

A Block 8 HT_mini_poal_new_bi... O |«

B Block 1 HT_mini_poel_new_bci... O v

B Block 2 HT_mini_pool_new_bci... [

B Block 3 HT_mini_pool_new bei... | [ |+

| B Block 4 HT mini_pool_new bei... | [ |+

B Block 5 HT_mini_pool_new_bci... O v

B Block & HT_mini_pocol_new_bci... O v

B Block 7 HT_mini_pool_new_bci... [

B Block & HT_mini_pool_new bei... | [ |+

Figure 2. The Import NGS Run window

/ NOTE: A plate layout can only be selected once for each panel type.
':_Q:'TIP: Drag-and-drop to reorganize plates in the Tree View.

NOTE: Open or clone project
To open an existing project, either:

¢ Select File > Open Project and browse for preferred project.

or

1. Select File -> Clone Project and browse for preferred project.

2. Browse for a folder to place the cloned project in. A folder with the same name with _CLONE added at the end will be
created.

23



Part 3: Operation
9. Start or open a project

9.2 Enter project information

For more information, refer to 7.1 Project. In the Project view of the main window:

1. Enter a Project Name. This will be displayed in the data export file and in the Analysis Report.

2. Enter Sample Matrix. This will be displayed in the data export file and in the Analysis Report.

3. Enter Comments for Project. This will not be displayed in the data export file and in the Analysis Report.

% NOTE: Any entered Comments will be saved in the Olink NPX Explore HT project file (.oaf)
and Flagged Positions will automatically be displayed in the Analysis Report.
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10. Perform quality controls

10. Perform quality controls

1. Perform review of overall QC for each plate separately using the Quality Control Summary tab.

2. Perform quality assessment for all plates using the other views.

3. Make an overall assessment.

lj NOTE: If a run fails to meet the acceptance criteria, please contact support@olink.com.

Criteria

FAIL

NPX is not calculated, exclude from

WARN
NPX is calculated, assess further, use

count in negative control

statistical analysis data with caution
Sample QC
Total counts per sample <10000 N/A
Incubation control counts per sample <150 <500
Extension control counts per sample <150 <1000
Amplification control counts per sample | <150 <500
External Control QC
Total counts per sample <10000 N/A
Incubation control counts per sample <500 N/A
Extension control counts per sample <1000 N/A
Amplification control counts per sample | <500 N/A
Plate control internal control counts < or > internal control reference range N/A
relative to assay counts to assay counts
Negative Control internal control counts | Negative control fails N/A
relative to assay counts
Block QC
Plate Controls passing external sample | <50% (minimum 3 Plate Control must N/A
QC pass QQC)
Negative Controls passing external sample <1 N/A
QC
Systematic effect (NPX) N/A >10% of assays
Systematic effect identified
Assay QC
Assay count relative to internal control N/A Assay count > any internal control count

If a run fails to meet the acceptance criteria, please contact support@olink.com.

10.1 Import rerun data

Mark the block to be excluded in the tree view.

S kA WP

Click Ok.

Select plate layouts for the Index Plate.

To only import the rerun block unmark the imported, not excluded blocks.

Right-click and select Exclude. The block will be light gray and the text (Excluded) is added to the block name.

Select File -> Import -> Import NGS Run Folder and browse to the preferred folder.
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Part 3: Operation
10. Perform quality controls

10.2 Additional quality assessment
Click the following tabs in the menu to assess the quality of the data in each tab and further determine if any reruns are
required. For more information about the tabs, refer to Part 2: User Interface.

¢ QC Supplementary table
Contains tables that display sample IDs and assays that failed or warned based on any of the QC criteria. The
information will help identify the possible root cause for sample and block failure.

e Sample QC overview
View and evaluate patterns of failed/warned samples within and across the blocks in each plate. Hovering over each
failed/warned sample to view the criteria that have resulted in failure or warning status.

¢ Plate data
View the values of NPX and Counts for internal controls and assays for each sample per block. Assess if there are
patterns in the plate (i.e. row or column) representing a possible technical error. Filter out the list of assays that reflect
any systematic effects by clicking on the type of effect in the “systematic effect filter” drop down menu.

¢ Plate variation
Display differences in sample distributions within and between plates.

NOTE: For intensity normalized projects, the assessment of this view should be performed using the Intensity
option for Normalization type after normalization has been performed.

e Correlation assays
Assess the correlations of each overlapping assay between blocks. Skewed data correlation in any of the plots can
indicate the technical error in the lab workflow.

e Heat map
Search for extreme outlier samples and systematic patterns that reflect a possible technical error.

e (CVtable
Assess the precision of the data based a group of pre-selected assays across different blocks on the Sample Controls.
The reported %CV is the mean %CV over all pre-selected assays. A high %CV does not fail a run automatically but could
indicate a technical issue or poor sample randomization and can be a cause for further investigation.
— Reference value for Inter %CV: <25%
— Reference value for Intra %CV: < 15%

e Control Sample variation
The box plot analysis is complementary to CV analysis to identify a sample control or plate that may be an outlier that
drives high CV.
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11. Export data & 12. Finalize a project

11.Export data

11.1 NPXfile

To export data as NPX file, perform the following steps:
1. Go to File -> Export.

2. Select NPX File.

3. Browse for a folder to save the file.

4. Click Save.

11.2 Analysis Report

To export an analysis report, perform the following steps (Steps 1-4 are optional):
Go to Project -> Analysis Report Input.

Fill in information that will be included in the Analysis Report.

Click Submit.

Go to File -> Export.

Select Analysis Report.

Browse for a folder to save the file.

Click Save.

12.Finalize a project

When the QC is done, the project can be marked as finalized.

® N O U A W NP

Select Project -> Project State -> Finalize.

When the project is finalized, all output files are generated. The project can still be viewed but cannot be modified.
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13. Data export files

13.Data export files

13.1 Parquet file format
NPX data is exported from Olink NPX Explore HT in Parquet file format. Parquet is a free open source file format built to
handle columnar storage data.

Parquet files provide several advantages compared to CSV, such as
* Much more efficient data compression with enhanced performance to handle complex data in bulk.

» Improved data integrity through binary encoding (files can't be opened and changed using a text editor).

The binary encoding also means the file cannot be opened in Microsoft® Excel. If required, Parquet files can be exported to
CSV format.

Parquet is available in multiple languages including Java, C++, Python, C# etc. You can find further details at these
locations
» https:/parquet.apache.org/docs/

» https://enwikipedia.org/wiki/Apache_Parquet

13.1.1 Recommended way of interacting with a Parquet file
Olink recommends installing and using DBeaver to view, query and export Parquet data.

Installing DBeaver
9. Download DBeaver for free from the Microsoft® Store by clicking on the start menu and type "Microsoft store".
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11. Once DBeaver is installed, setup a new database connection.

@ Deaver 2310

Part 3: Operation
13. Data export files

Eile Edit Navigate Search SOL Editog Datal
¢-|vey|Os. -alW

base | Window Help
New Databzse Connection

£ DatabaseNa.. X @ Projects = B
[ BT

Enter 2 part of object name here v

%

Driver Manager
Connect
Invalidate/Reconnect
Disconnect
Disconnect All

Disconnect Others

Read-only.

Open Dashboard Crb+Alt+ Shift+ B
Tools >
Contert tools At
Tasks >

12. Choose DuckDB and hit the Next button.

@ Connectto 3 database

Select your database

Create new database connection. Find your database driver in the list below.

o X

£ Full-text search
1 Graph databases

@

Type part of database/driver nametofilter # | Sortby: O Title @ Score

O3 Timeseries 3
[ Embedded ORACLE =50 \Se

— rver
£ Hadoop / BigData o

Oracie FosresaL SaL server sauie

ol .
MariaDg MysQ

Mariadg MysaL

d VA 9.

- S II e

13. Type ":memory:" in the Path input field.

() Connect to a database.

Generic JDBC Connection Settings
DuckDB connection settings

o x

Main  Driver properties
General

Connect by: @Host O URL

JDBC URL:_ jdbe duckdb:memory:

Patry [ :memory:

| open. || create

@ Youesn connection parameters. Connection details (name, type, ...)

Driver name; DuckDB

Driver Settings

| Test Connection .| | <Back

—
necs M Fnsh || cance

14. Click the gray arrow.

(%) DBeaver 23.1.0

| = Da.. x @Pr.
¢ -0

JEile Edit Mavigate Search SOL Editor
¢ - % &y Os. -ia

= 0

=":’§

Enter a part of object

nam| V. -

@ Mmemory
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15. Download driver files.

Part 3: Operation
13. Data export files

) Driver settings [u] X
Download driver files
Download DuckDB driver files
DuckDB driver files are missing. [Force download / overwrite
These files can be downloaded automatically.
Files required by driver
File Version  De
# org.duckdb:duckdb_jdbe:RELEASERELEASE 080 A
T https://raw. com/duckdb/du ICENSE
< >
You can change driver version by clicking en version column.
Then you can choose one of the available versions.
Oryou can obtain driver files by yourself and add them in driver editor.
Vendor website Download configuration
Edit Driver [ Download Cancel
Ee—

16. Open a new script window.

File Edit Navigate Searchf SQOL Editor Database Window Help
€ -| v & | 040 opensolscin

e X @P =

5

Ctrls Shift

17. Type a PostgreSQL query such as
SELECT * FROM 'C:/npxfile.parquet’.

Make sure that the path in double quotes refers to the NPX file you want to query.
18. Click the "Execute SQL query"

button

| @ s e s
i s

19. View the result.

Export data to a CSV file
1. Click Export data.

Gmemary + = memary + @5 G-

Exportto CSV ikt

| saecr- reom crparquenn

Exportto HTMLfies)

Swetnk | [
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3. Set the "Directory" field to a location on your hard drive.

1. Click Next.

@ owa Tonstr
Extraction satings
Database bl xvacion setings
< Bponagt e
< Bucionsetings ||
Formatsetngs
" bucatpe  [Snghaey
Gonlin Segmentiae: | Toow
CI0pennen comnectonts
Ossectraw count
Fechsize
Cseectedclomns oy
Dissectea owsonty
Sietek | (&)

2. Click Next.

Broceed Coneal

Part 3: Operation
13. Data export files

4. Click Next.

@ Data Teanster

@ Data Teanster o x
p—
e Formatting:
Output Binaries: Infine  Encoding:
o -
e
e
i
B o
Savetassk | &b

Output
Confgureexport autpt parameters

 Bperttaget Generl

< Formst esings
Output

Diectory: Cipmguet

Confirm

& Gotalsenings

Fie name patern: | S{ablel Somesamp]
Encoding
Wi o the single e
Clcompress
Ospioutputie 1/mun

2+ 10000000

[ e e =T

© You canusevaisbles n autout paametes
Rets

(SR —

ClShow exported i insstem xplorer
esecuteprocess Confiouee

See how you can st s to exteml sorsge on ur wiki

o | &

e e

el
@ vaaTonster o x
Confirm
Check et
< Gportinge o
M~ Source Cortener_ Sowre Torget Conteiner Toget
< Ouput Qe ST O L i G B
< Contim
Source setings Tagetstings
Tl seings s setings: -
st ype SNGLE QUERY Diectory Cparque
Stmesamp)
Enceing U0
Timestamp patr: MG
e BOME N
Compreszho
S NUNE
swewsk | & s
Bk =S | Broceed i Conel
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13. Data export files

13.1.2 Quick-check parquet-viewer
To quick-check the parquet, perform the following steps:

1.

2
3.
4.
5

Download ParquetViewer from the GitHub wepage: https:/github.com/mukunku/ParquetViewer/releases.

Install ParquetViewer and open it.

Drag and drop the parquet file to the application window.

Use the query input field to filter out desired datapoints, or use the Record Offset filed to jump in the file.

For more information or help, refer to the GitHub homepage: https:/github.com/mukunku/ParquetViewer/wiki/Basics.
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13.2 NPXfile

The NPX file is a Parquet-file that can be generated from NPX Explore HT.

Part 3: Operation
13. Data export files

The NPX file contains the following information about the project in table format:

Column Description Type Typical value
SamplelD The annotated sample ID String
Sample Type Type of sample String PLATE_CONTROL, NEGATIVE_
CONTROL, CONTROL, SAMPLE
WelllD Id for well String Capital letter A—H followed by
number 1-12
PlatelD Name of the plate the sample was run on String
DataAnalysisRefID Reference ID for data analysis String
OlinkID OlinkID for assay String
UniProt UniProt ID for assay String
Assay Gene name for assay String
AssayType Type of assay String Amp_ctrl, inc_ctrl, ext_ctrl
Panel Panel name String Explore_HT
Block Name of the block the sample was run on String 1,2,3,4,5,6,7,0r8
Count The total number of counts Integer Greater than orequal to 1
ExtNPX Intermediate value between count and NPX: log2 of the Double -1.94701
ratio between data-point Count value and the count for
the Extension Control assay for the same sample.
NPX NPX value Double
Normalization Type of normalization used in project String Plate control, Intensity or
EXCLUDED
PCNormalizedNPX NPX value displayed if plate control normalization has Double 1.735509
been chosen.
AssayQC Overall QC status for an assay String NA, PASS, WARN
SampleQC Overall QC status for a sample in a block String NA, PASS, WARN, FAIL
ExploreVersion Software version of the module in Olink NPX Explore HT | String

used for panel calculations and normalization
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13.3 Extended NPX file

The Extended NPX file is a Parquet-file generated by the Explore CLI and Olink NPX Explore HT.

The Extended NPX file contains all the columns in the NPX file, plus the set of additional columns listed below.
e IntraCV

e InterCV

¢ SampleBlockQCWarn
¢ SampleBlockQCFail

e BlockQCFail

¢ AssayQCWarn

For more information, refer to the Olink® Explore CLI Technical Information.

13.4 Analysis Report

The analysis report is a pdf-file that can be generated from NPX Explore HT and CLI.

The analysis report summarizes the quality analysis of the project. It contains basic information and descriptions of the
project. It also contains a summary of the Quality control including sample passed QC.

The Analysis Report contains the following:
¢ Project information
— Sample matrix
— Project specific comments
¢ Quality control
— QCsummary
— Data output
— Software version information
¢ Appendix - A table including the following columns
— Olink Panel
— Block
— UniProt
— Assay Olink ID
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14. Overview

Part 4: Quality Control

14.0Overview

Olink Explore contains a built-in quality control system using three internal and three external controls, which enables full
control over the technical performance of assays and samples. It is fully automated and is performed directly on Counts
and therefore can detect severe technical errors.

If the QC is not accurate, please contact support@olink.com.

14.1 Internal controls

Three internal controls are spiked into every sample for each block. The internal controls are designed to monitor the
quality of assay performance, as well as the quality of individual samples:

IMMUNO REACTION EXTENSION/LIBRARY AMPLIFICATION DETECTION
TTTIIIIIT
e — m |
TIIIIIIIT .I_-.:..';u;ljuf;,].; s
e

Incubation control

Extension control
Amplification control

Figure 3. Internal quality controls

Incubation Control (Immuno Control): The Immuno Control is a non-human antigen measured with PEA. This control is
included in the immuno reaction (incubation) and monitors potential technical variation in all three steps of the reaction.

Extension Control: The Extension Control is composed of an antibody coupled to a unique pair of DNA-tags. These
DNA-tags are always in proximity, so that this control is expected to give a constant signal independently of the immuno
reaction. This control monitors variation in the extension and amplification step.

Amplification Control: The Amplification Control is a complete double stranded DNA amplicon which does not require
any proximity binding or extension step to generate a signal. This control monitors the amplification/sample indexing step.

The Extension Control is used to calculate the NPX, refer to 15.4 Normalization, and the other two are used in Quality
Control.
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15.The QC workflow

Three internal controls are added to each sample to monitor the quality of assay performance, as well as the quality of

individual samples:
* Incubation Control

e Extension Control

e Amplification Control

Part 4: Quality Control
15. The QC overview

The Extension Control is used to calculate the NPX, refer to 15.4 Normalization, and the other two are used in Quality

Control (described below).

NPX_pc, NPX_int

- N 4
Plate QC Systematic
Effects
Row/column
Sample QC effect
Gradient
Block QC pattern
Assay QC
\_ ) N
PASS/WARN
s ™
Normalization
Plate
Control
Intensity
FAIL
N ¢ -
. Output:
Output: Count, ExtNPX,
Count
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15.1 Plate QC

The QC is performed directly on Counts, on one block per 96 samples. The Plate QC are divided into three parts:

15.1.1 Sample QC
Samples and external controls that fail Sample QC will not be considered for additional QC steps and not normalized. Only
counts will be reported for those.

1. Low total number of counts per sample per block
Too low total counts for a sample might indicate that the sample is missing or the index was not added to the sample.
Each sample and external control should have a minimum number of counts in a block, otherwise they fail.

2. Low number of counts of internal controls per block
Low counts in any of the internal controls might indicate a technical error in the workflow for the corresponding
sample, for example a missing internal control.

— Each external control should have a minimum number of counts for each of the internal controls, otherwise they
fail.

— Each sample should have a minimum number of counts for each of the internal controls, otherwise they fail or
get a warning.

3. Deviation of counts in Plate Controls
Deviation of internal control's counts from the expected ranges in Plate Controls might indicate different technical
errors.

— A PIate Control fails if the fraction of counts of all internal controls to total counts in logarithmic scale, deviates
positively or negatively from the reference values. The reference ranges are block specific and kit lot related.

4. Unexpected signal in Negative Controls
Detection of high number of counts for many assays, relative to the counts of internal controls, in any Negative
Controls might indicate that signals are from other sample types or not from pure buffer.

— A Negative Control fails if many assays get higher number of counts relative to the counts of internal controls.

15.1.2 Block QC
Block QC is to quality control whether a block-plate is affected by technical errors This step is performed only on the Plate
and Negative Controls that pass Sample QC. A failed block is recommended to be rerun.

1. Based on Plate Controls:

— Ablock-plate fails if <50% of Plate Controls pass the Sample QC (a minimum of 3 Plate Controls is required to
pass the block-plate).

2. Based on Negative Controls:
— Ablock-plate fails if none of the Negative Control pass the Sample QC.

15.1.3 Assay QC
Detection of high number of counts for any assay, relative to the internal controls, in any of the Negative Controls is
considered as unexpected signal. This step is performed on Negative Controls that pass Sample QC.

¢ An assay gets a QC warning if it gets high number of counts relative to the counts in internal controls in all Negative
Controls.

For acceptance criteria for Sample QC, Block QC and Assay QG, refer to table in 10. Perform quality controls.
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15.2 Systematic effect detection

Systematic effects are defined as a systematic pattern on a plate caused by a deviation in the workflow such as
instrument failure or human error. A pattern corresponds to a particular type of failure. Detection of systematic effects is
complementary to the Plate QC and is performed on NPX. All samples and data-points (passed, failed, and warned) are
included in the computation.

Systematic effects are categorized into patterns that impact the full plate orimpacting a row or/and column. To detect the
patterns, three main criteria are considered:

¢ The frequency of assays representing the effect
¢ Theintensity of the effect on NPX deviation

¢ Number of samples showing the effect

A pattern is detected per assay/block/plate unit. If enough assays (internal controls are not included) are affected, the
block will get a systematic effects warning corresponding to that effect in NPX Explore HT Software (Quality Control
Summary tab). Systematic effects may be due to either non-randomized plate design or technical errors and should be
investigated further when warned.

15.2.1 Types of systematic effects
* Row

e Column

e Four_column

¢ Alternating_column
¢ Row_gradient

e Column_Gradient

¢ Diagonal_Gradient

15.3 Summary notes for exported data

¢ Data related to all assays, including the internal controls, will be presented in the output NPX file.
¢ Data related to all samples, including the external controls, will be presented in the output NPX file.

« Data related to any failed sample or block that do not pass QC criteria will not be normalized and therefore no NPX will
be computed. Counts are reported for the failed data-points in the NPX file.

¢ Any data-points with a QC warning should be used with caution.

For any more information about Plate QC and systematic effects, please contact support@olink.com.
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15.4 Normalization

The two between-plate-normalization methods are called Plate Control (PC) normalization and intensity normalization.
They both adjust each assay per plate to a median, but they differ in how these medians are calculated. An important
concept when selecting normalization procedure is randomization, which in this context applies to the sample placement
across the plates. For details, refer to Randomization FAQ on the Olink website.

Plate Control normalization should be selected for all Explore HT project (projects with single or multiple plates, projects
where complete randomization of samples can not be guaranteed, etc). Plate Control normalized NPX will by default be
reported in the output NPX file. Contact support for study design assistance and choosing the appropriate normalization

type.

15.4.1 Counts

The Olink Explore system’s raw data output is counts, where each combination of assay and sample is given an integer
value based on number of copies detected. These raw data counts are converted into NPX values for use in the continued
analysis.

15.4.2 Converting counts to NPX

Converting counts to NPX The Olink Explore system’s raw data output is counts, where each combination of assay and
sample is given an integer value based on number of copies detected. These raw data counts are converted into NPX
values for use in the continued analysis.

NPX generation

The NPX values are calculated in two main steps, followed by an optional additional step between-plate-normalization.
First, the assay counts of a sample are divided with the Extension Control for that sample and block. The resulting scale
has increasing values with increasing concentration for each assay. A log2 transformation is applied and the final step is
subtracting the median of the Plate Controls. The optional additional step is intensity normalization which sets the median
level of all assays to the same value for all plates. The different steps are described below.

Steps in the NPX generation described in equation form, where i refers to a specific assay, j refers to a sample, and ExtNPX
defines an extension normalized NPX value.

1. ExtNPX_i, j = log2(counts(sample_jAssay_i)/counts (ExtCtrl_j))
a. Relate counts to known standard (Extension Control).
b. Forall assays and all samples, including Negative Controls, Plate Controls, and Sample Controls.
¢. Log2 transformation gives more normally distributed data.
2. NPX_i, j = ExtNPX_i, j-median (ExtNPX(Plate Controls_i))
a. Perform plate standardization.
b. For all assays and per plate of samples.
3. NPX_Intnorm_i,j = (ExtNPX_i,j - plate median(ExtNPX_i))
a. Between plate normalization.

b. Foreach assay, for all plates in project.
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15.4.3 CV calculation

To evaluate the reproducibility and repeatability of data related to each plate in the project, and to assess the within- and
between-plate variation in the project, two types of CV are computed for each of the pre-selected assays: within plate
(intra CV) and between plates (inter CV) in Sample Controls. For the inter CV calculation, the mean of Sample Controls is
used to represent the plate before CV calculation.

In each block, pre-selected assays with good performance in Olink Sample Controls are used so that any deviating CV
actually indicates a potential technical issue within the workflow. The CV is calculated for NPX of those selected assays (i),
using the assumption of a log-normal distribution, in Sample Controls using the formula below. The CV is part of the Ul
assessing run quality, and is presented in a CV Table showing average CV:s over the blocks

Cv, = 100 V( e’ - 1), where Sln, = 1In(2) x SDisk
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16. Troubleshooting

This chapter includes a trouble shooting guide, describing QC issues, affected level (sample, block, plate) and possible root
causes for some potential non-expected results. Reruns are not recommended except for the projects that have failed to
pass formal QC. Please contact support@olink.com for further investigations and receiving appropriate guidance for any

of these cases.

QCissue

Plate Controls and/or samples fail

Affected
samples/blocks/Sample plates

Possible cause

Failed Plate Controls:
Deviation from reference values (+)

Multiple blocks (1-4 or 5-8)
Both sample plates plates

— Dilution plates or Sample Plate
swapped positions on Mosquito
— Wrong dilution protocol was used

Plate Controls fail:

Deviation from reference values
(Inc & Ext -, AMP +)

(Inc, Ext &AMP -)

Multi blocks in both Sample plates

Poor PCR enzyme efficiency due
to not adding enough Enzyme A or
Enzyme B

Plate Controls fail:

Deviation from reference values
(Inc-,Amp & Ext +)

— Low counts for Incubation Controls
— Low counts for assays

— High counts for Amplification and External
Controls

The same single block in both Sample
Plates (e.g. Block 2 in SP1 and SP2)

1A: Forward probe was not added to
the incubation reagent mix

1B: Not enough incubation solution
was added while preparing the
reagent mix

The same two blocks in both Sample
Plates (e.g. Blocks 2 and 5 in SP1 and
SP2)

2A: Forward probes were mixed up
for the two blocks when preparing
incubation mix (wrong pair of probes)

2B: Not enough incubation solution
was added while preparing the
reagent mix

Samples and/or external Controls fail:
Too low counts

1. One or multi samples in a block
One or both Sample Plates.

1. Incubation reagents mix or index
not added properly due to Mosquito
pipetting error

2. All or multi samples in multi blocks
(Likely blocks 1-4)
Both Sample Plates.

2. Poor sequencing if %PF is low

Samples and Plate Controls fail:

Too low counts
— Low counts for assays
— Low counts for all internal controls

1. One same block in both Sample
plates (e.g. Block 2 in SP1 and SP2)

1. Reverse probe was not added into
incubation reagent mix

2. The same two blocks in both
Sample plates (e.g. Blocks 2 and 5 in
SP1and SP2)

2. Reverse probes were mixed up

for the two blocks when preparing
incubation mix (wrong pair of
probes). Amplification Control might
have some counts.
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Negative Control fail

Negative Controls fail
(Plate Controls might fail too)

1. Multi blocks in one Sample Plate
(likely blocks 5-8)

1A. The plate layout does not match
with the uploaded run.

1B. NCs related to one of the Sample
Plates were pipette into wrong wells
on Sample Source Plates.

1C. Negative Controls are
contaminated

2. The same multi blocks in both
Sample Plates (blocks 1-4 or 5-8)

2A. Sample Source Plates was rotated
in the workflow

2B. Samples added instead of
Negative Controls in Sample Source
Plates

2C. Index plate A and B were swapped
positions on mosquito between the
two stages of adding indexes

2D. Negative Controls are
contaminated

Systematic effect

Alternating column effect:
NPX value deviates in every other column

1 2 3 4 5 6 7 8 9

T O TMmMOM @B

One or multiple blocks in one or both
Sample Plates

10 11 12

Mosquito pipetting error while
dispensing reagent mix into
incubation plate

Every 4 columns effect:
NPX values deviate between every 4 columns

5 6 7 8

IO Tm"mOoOMN®>

Two blocks in both Sample Plates

9 10 11 12

— Dragonfly faulty syringe during
dispensation of PCR mix
— Not well vortex of PCR mix

Row effect:

NPX values deviate between samples in one
row and samples in all other rows

1 2 3 4 5 6 7 8 9

T OT MO @ >

Same row in the same block in both
Sample Plate

10 11 12

ﬁ

— EpMotion pipetting error when
pooling the samples

— Human error missing one well
during pooling step
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Gradient patterns
(row/column/diagonal wised):

NPX Values deviate gradually in samples
across the plate in row, column, or diagonal

pattern
1
A
B
C
D
E
F
G
H

3

4

5

[

7

9 10

One or multi blocks in both Sample
Plates

1 12

— Not well vortex of reagent mix/
plates

— Not well adjusted/calibrated
instruments
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1/. Revision history

Version  Software Description
version
22 v2.2 2023-12-01 | 73 added.
13.1.2 added.

Version number updated to match the software version(v.1.1-v2.1
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11 v2.1 2023-10-09 | 72 77 and 710 supplementary information added.
9.1 supplementary information added.

11.2 supplementary information added.

13.4 supplementary information added.

15.2.1 new.

1.0 v2.0 2023-08-14 | New
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