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Part 1: Introduction
Olink high-multiplex immunoassay panels provide an efficient and innovative tool for targeted human protein biomarker 
discovery, development and validation.

1. About this manual
This user manual provides you with the instructions needed for data processing when running Olink® Explore panels with 

a locally installed set up of software. 

NOTE:  The information in the NPX™ Explore HT & 3072 User Manual is believed to be accurate. However, the 
displayed screenshots may differ from actual user interface and should be considered as examples. 

1.1 Intended use
NPX™ Explore HT & 3072 is a data analysis software that is designed for Olink® Explore platforms. It allows for importing 
data, validating data quality, and normalizing Olink data for subsequent statistical analysis.

NPX™ Explore HT & 3072 is intended for research use only. Not for use in diagnostic procedures. All trademarks and 
copyrights contained in this material are the property of Olink® Proteomics AB unless otherwise stated. For questions, 
guidance, and support, contact Olink Support at support@olink.com.

1.2 Intended target group
NPX™ Explore HT & 3072 is intended to be used by staff certified to run the Explore HT platform. Quality control should 
be performed by trained users that determine whether data from a run can be approved for further analysis.

2. List of abbreviations
%CV Coefficient of Variance

NGS Next Generation Sequencing

PCR Polymerase Chain Reaction

PEA Proximity Extension Assay

QC Quality Control

SD Standard Deviation

Part 1: Introduction 
1. About this manual & 2. List of abbreviations
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Part 1: Introduction
3. Associated documentation & 4. Technical support

3. Associated documentation

3.1 Olink documentation
• Olink® Explore Preprocessing Technical information, v4.5.0 or later

• NPX™ Explore CLI HT & 3072, v2.3.0 or later

• Olink® Explore HT User Manual

• Olink® Explore Sequencing using NextSeq 550 User Manual

• Olink® Explore Sequencing using NextSeq 2000 User Manual

• Olink® Explore Sequencing using NovaSeq 6000 User Manual

• Olink® Explore Sequencing using NovaSeq 6000 S4 User Manual

• Olink® Explore Sequencing using NovaSeq X Plus User Manual

All relevant Olink documentation is available from the Olink website www.olink.com/downloads.

3.2 Other documentation 
• Article & lot configuration sheet - delivered together with the analysis kit.

4. Technical support
For questions, guidance and support, contact Olink Proteomics at support@olink.com.

https://www.olink.com/resources-support/document-download-center/
mailto:support%40olink.com?subject=
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5. Process

5.1 Hardware and software requirements

5.1.1 System requirements for NPX™ Explore HT & 3072
Components Minimum Recommended

Operating System Windows® 10 or higher

Processor Intel® Core™ i5 Intel® Core™ i7 or higher

Memory 8 GB RAM 16 GB RAM or more

Disk Space 500 GB 500 GB

5.1.2 System requirements for Pre-processing
Components Minimum Recommended

Operating System Linux

Other Linux administrative knowlede

5.1.3 Requirements for analysis
Files and information needed for analysis:

• Count files in CSV format and run metadata in JSON format (NGS raw data pre-processed using ngs2counts) 

• Plate layout with sample names

• Data analysis reference ID number of reagents used (provided on the Lot configuration insert delivered with the kit)

5.2 Pre-processing runs
Preprocessing is a necessary step in all NPX™ Explore analyses. During preprocessing, the Next Generation Sequencing 
(NGS) output from the sequencing instrument is converted to counts files containing the number of reads for each Olink® 
sequence and a run metadata file containing additional information which is necessary for importing the counts files into 

the analysis software NPX™ Explore HT & 3072, or into NPX™ Explore CLI HT & 3072.

Read the Olink® Explore Preprocessing Technical information and the NPX™ Explore CLI HT & 3072 Technical information.

Part 1: Introduction
5. Process
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5.3 CLI
QC and normalization of Olink® Explore HT data can be performed either using the NPX™ Explore HT & 3072 software or 
using the NPX™ Explore CLI HT & 3072 software or using a combination of the two.

Pre-processing Counts NPX Explore HT Extended NPX file

Explore 
project

Output data

Plate Layout 
files

Analysis Report
Explore 

Calculation Module

Explore CLI

Explore 
Calculation Module

Raw 
NGS data 

NPX™ Explore CLI HT & 3072is a command-line interface (cli) for Olink® Explore products. The application is capable of 
performing normalization, quality control (QC) and CV computations on NGS data and exporting the results on several 
supported formats. For more information, refer to the NPX™ Explore CLI HT & 3072 Technical Information.

Part 1: Introduction
5. Process
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Part 2:  User Interface

6. General
The NPX Explore HT & 3072 user interface consists of several views on separate tabs where information and results are 
displayed. These views are described in this chapter. 

6.1 Search
Use Ctrl + F to open a search field. The search function works on most views for either plain text or sample names, assay 
names or Uniprot IDs. The first match found will be highlighted. The search function is also available from Edit > File.

6.2 Help
Press F1 to open the NPX Explore HT & 3072 User Manual as a PDF file. The manual can also be downloaded from  
www.olink.com/downloads.

6.3 Tree view
The tree view displays the plates and the imported data for each plate.

 
Tree view for NPX® Explore HT & 3072  Tree view for NPX® Explore 3072

• Click on the + next to the Plate name to display the imported data for each plate.

• Mark an individual block to see information about that specific block. If a plate is highlighted in the Tree View, 
information for the first block is displayed on the specific tabs.

• Right-click on a block to recalculate, delete, include or exclude a block. 

NOTE:  If there is panel plates with missing data, a window will be prompted. Contact support@olink.com  
for support.

Part 2. User Interface
6. General
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6.4 Selection information
The Selection Information view in the lower left corner displays information about the currently selected item in the Tree 
view. 

Item Description

# Block Selected block.

# Samples Number of samples, excluding control samples, in selected Olink panel or run.

#Experiment name Experiment specific name.

# Index plate Panel specific index plate.

# Inclusion status Shows included or excluded status of the panel.

# Version status Shows if the version is up to date or outdated.

Part 2. User Interface
6. General
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7. Tabs

7.1 Project
The Project tab contains fields for entering and saving project information.

7.1.1 Project Name
The project name is displayed in the NPX data output file and the Analysis Report.

7.1.2 Sample Matrix
This field is used to describe the sample matrix, e.g. “Plasma” or “Serum”. The information is displayed in the Analysis 
Report.

7.1.3 Comments for Project
Write a message in the box next to the Comment button. Click the Comment button to add the message in the Comments 
for Project field. The comments will only be visible in the project tab and not be generated into the Analysis Report.

Copy a comment by right-clicking on the comment and selecting Copy.

7.1.4 Data Analysis Reference ID
This field displays data analysis reference ID for the blocks included in the project.

Part 2: User Interface 
7. Tabs



11

7.2 Plate Layouts
General:

The Plate Layouts tab shows the sample plate setup for the selected run, and general information about the run.

Each sample position is automatically annotated to one of the following content types, based on the sample naming:

• White: SAMPLE

• Red: PLATE_CONTROL

• Blue: NEGATIVE_CONTROL

• Yellow: SAMPLE_CONTROL

• Dark grey: EMPTY

• Light grey: NOT_USED

Neither EMPTY or NOT_USED wells are covered by the NPX calculations. EMPTY shows counts while NOT_USED shows 

nothing.

Useful for:

• Getting an overview of the plate setup, one block at the time.

Functions:

• Choose block to display in the tree view.

• Information about the plate is shown below the plate layout.

Part 2. User Interface
7. Tabs
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7.3 Run Log
General:

The Run Log tab shows a detailed list of all run units at either plate or block level. Each run has a comment window where 
users to make notes in.

Useful for:

• Making comments on run unit level for others working on the same project.

• Getting an overview of run unit details.

Functions:

• Write a comment in the comment window for a run. Click Submit to save the comment or Reset to remove it. 

• Add a rerun and edit its information.

• To submit comments and/or changes in more than one run unit, click Submit all, found above the list.

• For each plate, the following information is displayed:

Fixed information Editable information

• Sequencing date

• Sample source (SS) plate name

• Run name

• Data analysis Ref ID

• Index plate

• Instrument ID

• Count file

• Flowcell information: ID, type and side

• Library

• Plate control and negative control yes/no

• Rerun of

• Manual assessment

• Primary cause

• Step failed 

• Rerun needed no/yes

• Inclusion status

• Information about a rerun can be added in the editable information part, for example instrumental or human error.

Part 2: User Interface 
7. Tabs
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7.4 Quality Control Summary
General:

The Quality Control Summary tab displays a summary of the QC criteria per block. Refer to 14. Overview for description of 
the QC criteria.

Useful for:

• Reviewing failed blocks/samples.

• Finding systematic effects.

Functions:

• For each plate, the following information is displayed:

 – Plate ID

 – Panel

 – Block

 – Failed samples

 – Failed PC

 – Failed NC

 – Failed Sample Control

 – Warned assays

 – Block QC

 – Systematic effects

 – Counts

 – % Passed

Part 2: User Interface 
7. Tabs
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7.5 Supplementary Tables
General:

The supplementary Tables tab contains five tables displaying samples that have failed or have warnings based on QC 
criteria. All data for one sample source plate is displayed at a time.

Only tables that contain data will be displayed.

Useful for:

• Reviewing flags of all samples and assays in tables, divided into five different flag reasons:

 – Assay warnings

 – Samples with low total counts

 – Samples with low internal control count

 – Deviating plate controls

 – Failed negative controls

Functions:

• The following information will be displayed in the different tables:

Assay warnings Samples with low 
total couns

Samples with low 
internal control count

Deviating Plate 
Controls

Failed Negative 
Controls

• Plate ID

• Panel

• Block

• Assay

• Olink ID

• Plate ID

• Panel

• Block

• Well ID

• Sample ID

• Sample type

• Total count

• Plate ID

• Panel

• Block

• Well ID

• Sample ID

• Sample type

• Amp count

• Ext count

• Inc count

• Plate ID

• Panel

• Block

• Well ID

• Sample ID

• Amp

• Ext

• Inc

• Plate ID

• Panel

• Block

• Well ID

• Sample ID

• Sample Type

• The Failed Negative Controls table includes empty wells that show too high signal.

• To export the information, mark whole or parts of the table, right-click and choose Copy. Open preferred program, and 
paste the information. 

Part 2. User Interface
7. Tabs
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7.6 Correlation Assays
General:

The Correlation Assays tab shows correlation assays that overlaps across the blocks per sample plate.

• A plate is chosen: all included run units are shown. 

• An excluded run unit is chosen: the text "No data display" is shown. 

• Failed samples: no data points will be shown.

• Failed blocks: an empty graph with red text "Block QC failed [NPX] "will be shown.

Correlation assays are GBP1 (uniprot P32455) and MAP2K1 (uniprot Q02750).

Useful for:

• Getting an overview of correlation assays.

Functions:

• Use the Assay drop-down list to switch between correlation assays.

• Zoom in and out with scroll wheel or touch pad.

Part 2: User Interface 
7. Tabs
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7.7 Plate Variation
General:

The Plate Variation tab displays a box plot with NPX values from the Sample wells. Failed run units will be left empty, refer 
to the left run in the picture below.

Useful for:

• Detecting systematic variance in total intensity between plates.

Functions:

• Use the Assay drop-down list to show specific a assay.

• Use the Block drop-down list to show specific a block. (Only in NPX Explore 3072 mode)

• Select All in the Assay drop-down list to view the summary of all assays for each sample.

• To highlight a plate, press ctrl+f or go to edit -> find and type in part of a plate name.

It is not possible to toggle between the normalization types. To change the type, go to Project -> Normalization and 
choose type.

Part 2. User Interface
7. Tabs
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7.8 Plate Data
General:

The Plate Data tab shows heatmaps of one unit a time, including the internal controls: extension control, incubation 
control and amplification control. Empty wells show counts but not NPX.

The heatmap displays deviations from the plate median for the selected assay using the colors blue and red: 

• Blue: values below median

• Red: values above median. 

Warnings are marked with flags in yellow and red:

• Yellow flag: indicates warning.

• Red flag: indicates fail.

For NPX Explore 3072 projects, all blocks included in the selected plate are shown at the same time.

Useful for:

• Inspecting counts and NPX across a plate for each assay.

• Discovering systematic patterns.

• Discovering plates swap based on data pattern across the plate (If the plate has any empty well).

Functions:

• Change values by selecting either NPX or Counts.

• Use the assay drop-down menu to change which assay to display.

• Use the Systematic effect filter to switch off or show either column or row effect.

• Hover over a well to show:

 – Sample 

 – Well ID

 – Value

 – Deviation from median

Part 2: User Interface 
7. Tabs
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7.9 CV Table
The CV Table tab shows the CV information, one row per block. CV is calculated based on the data points of Sample 
Controls that passed the QC criteria. 

Useful for:

• Getting an overview of the CV values per block, and which blocks that have missing CV values.

Functions:

• The following information will be displayed:

 – Panel type (Only in NPX Explore 3072 mode)

 – Block

 – Intra-assay %CV mean

 – Inter-assay %CV mean

 – Normalization

• Choose which panel to be shown in the tree menu.

• To export the information, mark whole or parts of the table, right-click and choose Copy. Go to preferred program, and 
paste the information.

• Missing values for Intra CV mean and Inter CV mean are represented by NA.

Part 2. User Interface
7. Tabs



19

7.10 Heatmap
General: 

The Heatmap tab contains a color-coded view for all assays and samples in the chosen block. The assays are displayed in 
the horizontal direction and samples in vertical direction. Empty wells show counts but not NPX.

The heatmap displays deviations from the plate median for the selected assay using the colors blue and red: 

• Blue: values below median

• Red: values above median. 

Useful for:

• Finding systematic patterns.

• Finding outlier samples for specific assays.

Functions:

• Switch sort order between row and column.

• Select sample type to display. (All samples, Sample, Plate Control, Negative Control, Sample Control, or Empty)

• Select block to display. (Only in NPX Explore 3072 mode)

• Change values by selecting either NPX or Counts.

• Select systematic effect (Off, Column effect, or row effect). (Row effect only in NPX Explore HT & 3072 mode)

• Hover over a well to show:

 – Assay

 – Sample ID

 – Well ID

 – Deviation from assay median

 – NPX

• Zoom in and out with scroll wheel.

• Move the map to see different assays by clicking and holding the left mouse button and drag the heatmap.

Part 2: User Interface 
7. Tabs
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7.11 Sample QC Overview
General:

The Sample QC Overview displays a color-coded heatmap showing status for each sample in all blocks.

• Blue: Pass

• Red: Fail

• Yellow: Warning

If a sample has both a fail and a warning, it is shown as fail.

Useful for:

• Finding systematic errors across different blocks.

Functions:

• Switch between sort order Row and Column.

• Hover over the cells provides information on:

 – Sample ID

 – Block

 – Well ID

 – For failed and warned samples: reason for failure or warning.

Part 2. User Interface
7. Tabs
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7.12 Sample Control Variation
General:

The sample control variation view displays data for all Sample Controls in the entire project. Data points for both internal 

control assays and regular protein assays are included.

NOTE:  The range of the Y-axis differs between the blocks.

Useful for:

• Getting an overview of the variation of the sample controls through blocks and plates.

Functions:

• Select Panel type in the drop-down menu. (Only in NPX Explore 3072 mode)

• Every row represents a block and every column a plate.

• Each boxplot represents non-failed Sample Control with NPX values.

• Excluded run units are not shown.

• Missing plate-block gives empty sub-boxplots.

Part 2. User Interface
7. Tabs
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7.13 Audit Log
General:

The Audit Log tab displays all events for the current project.

Useful for:

• Seeing what actions that has been done on the project.

Functions:

• The upper table shows changes not yet saved.

• The lower table shows changes that has been saved.

Part 2. User Interface
7. Tabs
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Part 3: Operation

8. Introduction
Input data is counts files and metadata files generated by ngs2counts. For more information on pre-processing, refer to  
5.2 Pre-processing runs.

This section describes how you analyze data step-by-step in NPX Explore HT & 3072. The following steps are included in 
the standard operating procedure:

1. Select type of project

2. Import run files (Plate layouts and NGS run folder) or open or clone a project.

3. Enter project information.

4. Perform quality controls including additional quality assessment.

5. Export data.

6. Create an Analysis Report.

7. Finalize the project

3

2

1

1
1 Type of project

2 Information box displaying statistics about the currently selected item

3 Tree view showing Olink panels and blocks

4 Main work area

Part 3: Quality Control 
8. Introduction
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9. Start or open a project

9.1 Select type of project
Before creating a project, the type of project must be selected.

• Select File -> New Project. Choose Explore HT or Explore 3072, depending on the project that shall be created. The 
text in the down left corner changes to the selected project type.

9.2 Import run files
To create a project, the following files must be imported:

• Plate layouts

• NGS run folder

1. Select File -> Import -> Import Plate Layouts - standard and browse to the preferred plate layout(s). 

2. Select Project -> Select Data Analysis Reference IDs to verify that the correct panels has been selected. 

3. Select File -> Import -> Import NGS Run Folder or File -> Import -> Import NGS Run Zip File,  depending on the 
format. Browse to the preferred folder or file. 

4. Select plate layouts for Index Plates and click Ok. For NPX Explore 3072 projects, this can be done either by choosing 
one or all libraries.

NOTE:  A plate layout can only be selected once for each panel type.

TIP:   Drag-and-drop to reorganize plates in the Tree View.

Part 3: Operation 
9. Start or open a project
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9.3 Open or clone project
To open an existing project, either:

• Select File > Open Project and browse for preferred project.

or

1. Select File -> Clone Project and browse for preferred project. 

2. Browse for a folder to place the cloned project in. A folder with the same name with _CLONE added at the end will be 
created.

9.4 Enter project information
For more information, refer to 7.1 Project. In the Project view of the main window:

1. Enter a Project Name. This will be displayed in the data export file and in the Analysis Report.

2. Enter Sample Matrix. This will be displayed in the data export file and in the Analysis Report.

3. Enter Comments for Project. This will not be displayed in the data export file and in the Analysis Report.

NOTE:  Any entered Comments will be saved in the NPX Explore HT & 3072 project  file (.oaf) and Flagged 
Positions will automatically be displayed in the Analysis Report.

Part 3: Operation 
9. Start or open a project
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10. Perform quality controls
1. Perform review of overall QC for each plate separately using the Quality Control Summary tab.

2. Perform quality assessment for all plates using the other views.

3. Make an overall assessment. 

NOTE:  If a run fails to meet the acceptance criteria, please contact support@olink.com. 

Criteria FAIL

NPX is not calculated, exclude from 

statistical analysis

WARN

NPX is calculated, assess further, use 

data with caution

Sample QC

Total counts per sample < 10 000 N/A

Incubation control counts per sample < 150 < 500

Extension control counts per sample < 150 < 1000

Amplification control counts per sample < 150 < 500

External Control QC  

Total counts per sample < 10 000 N/A

Incubation control counts per sample < 500 N/A

Extension control counts per sample < 1000 N/A

Amplification control counts per sample < 500 N/A

Plate control internal control counts 
relative to assay counts

< or > internal control reference range 
to assay counts

N/A

Negative Control internal control counts 
relative to assay counts

Negative control fails N/A

Block QC

Plate Controls passing external sample 
QC

For Olink Explore HT: 
< 50% (minimum 3 Plate Controls must 
pass QC) 

N/A

For Olink Explore 384 panels:

All 3 Plate Controls must pass QC.

N/A

Negative Controls passing external 
sample QC

< 1 N/A

Systematic effect (NPX) N/A >10% of assays 

Systematic effect identified

Assay QC

Assay count relative to internal control 
count in negative control

N/A Assay count > any internal control count

NOTE:  For more acceptance criteria for Olink Explore 384 panels, please contact support@olink.com.

If a run fails to meet the acceptance criteria, please contact support@olink.com.

Part 3: Operation 
10. Perform quality controls
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Part 3: Operation 
10. Perform quality controls

10.1 Import rerun data
1. Mark the block to be excluded in the tree view.

2. Right-click and select Exclude. The block will be light gray and the text (Excluded) is added to the block name.

3. Select File -> Import -> Import NGS Run Folder and browse to the preferred folder. 

4. Select plate layouts for the Index Plate.

5. To only import the rerun block unmark the imported, not excluded blocks. 

6. Click Ok.

10.2 Additional quality assessment 
Click the following tabs in the menu to assess the quality of the data in each tab and further determine if any reruns are 
required. For more information about the tabs, refer to Part 2:  User Interface.  

• QC Supplementary table 
Contains tables that display sample IDs and assays that failed or warned based on any of the QC criteria. The 
information will help identify the possible root cause for sample and block failure.   

• Sample QC overview 
View and evaluate patterns of failed/warned samples within and across the blocks in each plate. Hovering over each 
failed/warned sample to view the criteria that have resulted in failure or warning status.

• Plate data 
View the values of NPX and Counts for internal controls and assays for each sample per block. Assess if there are 
patterns in the plate (i.e. row or column) representing a possible technical error. Filter out the list of assays that reflect 
any systematic effects by clicking on the type of effect in the “systematic effect filter” drop down menu.

• Plate variation  
Display differences in sample distributions within and between plates.

NOTE:  For intensity normalized projects, the assessment of this view should be performed using the Intensity 
option for Normalization type after normalization has been performed.

• Correlation assays 
Assess the correlations of each overlapping assay between blocks. Skewed data correlation in any of the plots can 
indicate the technical error in the lab workflow. 

• Heat map 
Search for extreme outlier samples and systematic patterns that reflect a possible technical error.

• CV table 
Assess the precision of the data based a group of pre-selected assays across different blocks on the Sample Controls. 
The reported %CV is the mean %CV over all pre-selected assays. A high %CV does not fail a run automatically but could 
indicate a technical issue or poor sample randomization and can be a cause for further investigation. 

 – Reference value for Inter %CV: < 25%  

 – Reference value for Intra %CV: < 15% 

• Control Sample variation  
The box plot analysis is complementary to CV analysis to identify a sample control or plate that may be an outlier that 
drives high CV.
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Part 3: Operation 
11. Export data & 12. Finalize a project

11. Export data

11.1 NPX file
To export data as NPX file, perform the following steps:

1. Go to File -> Export.

2. Select NPX File.

3. Browse for a folder to save the file.

4. Click Save.

11.2 Analysis Report
1. To export an analysis report, perform the following steps (Steps 1÷4 are optional):

2. Go to Project -> Analysis Report Input.

3. Fill in information that will be included in the Analysis Report.

4. Click Submit.

5. Go to File -> Export.

6. Select Analysis Report.

7. Browse for a folder to save the file.

8. Click Save.

12. Finalize a project
When the QC is done, the project can be marked as finalized.

Select Project -> Project State -> Finalize.

When the project is finalized, all output files are generated. The project can still be viewed but cannot be modified. 
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13. Data export files

13.1 Parquet file format
NPX data is exported from NPX Explore HT & 3072 in Parquet file format. Parquet is a free open source file format built to 
handle columnar storage data.

Parquet files provide several advantages compared to CSV, such as

• Much more efficient data compression with enhanced performance to handle complex data in bulk.

• Improved data integrity through binary encoding (files can't be opened and changed using a text editor).

The binary encoding also means the file cannot be opened in Microsoft® Excel. If required, Parquet files can be exported to 
CSV format.

Parquet is available in multiple languages including Java, C++, Python, C# etc. You can find further details at these 
locations

• https://parquet.apache.org/docs/

• https://en.wikipedia.org/wiki/Apache_Parquet

13.1.1 Recommended way of interacting with a Parquet file
Olink recommends installing and using DBeaver to view, query and export Parquet data. 

Installing DBeaver

1. Download DBeaver for free from the Microsoft® Store by clicking on the start menu and type "Microsoft store". 

2. Type "DBeaver" in the search field, and press Enter. 

Part 3: Operation 
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3. Once DBeaver is installed, setup a new database connection. 

4. Choose DuckDB and hit the Next button. 

5. Type ":memory:" in the Path input field. 

6. Click the gray arrow. 

Part 3: Operation 
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7. Download driver files. 

8. Open a new script window.  

9. Type a PostgreSQL query such as  
SELECT * FROM 'C:/npxfile.parquet'.  
Make sure that the path in double quotes refers to the NPX file you want to query.

10. Click the "Execute SQL query" button 

11. View the result. 

Export data to a CSV file

1. Click Export data. 

2. Highlight CSV and click Next. 

Part 3: Operation 
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1. Click Next. 

2. Click Next. 

3. Set the "Directory" field to a location on your hard drive.

4. Click Next. 

5. Click Proceed. 

Part 3: Operation 
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Part 3: Operation 
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13.1.2 Quick-check parquet-viewer
To quick-check the parquet, perform the following steps:

1. Download ParquetViewer from the GitHub wepage: https://github.com/mukunku/ParquetViewer/releases.

2. Install ParquetViewer and open it.

3. Drag and drop the parquet file to the application window.

4. Use the query input field to filter out desired datapoints, or use the Record Offset filed to jump in the file.

5. For more information or help, refer to the GitHub homepage: https://github.com/mukunku/ParquetViewer/wiki/Basics.

https://github.com/mukunku/ParquetViewer/releases
https://github.com/mukunku/ParquetViewer/wiki/Basics
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13.2 NPX file
The NPX file is a Parquet-file that can be generated from NPX Explore HT & 3072. 

The NPX file contains the following information about the project in table format:

Column Description Type Typical value

SampleID The annotated sample ID String

Sample Type Type of sample String PLATE_CONTROL, NEGATIVE_
CONTROL, CONTROL, SAMPLE

WellID Id for well String Capital letter A÷H followed by 
number 1÷12

PlateID Name of the plate the sample was run on String

DataAnalysisRefID Reference ID for data analysis String

OlinkID OlinkID for assay String

UniProt UniProt ID for assay String

Assay Gene name for assay String

AssayType Type of assay String Amp_ctrl, inc_ctrl, ext_ctrl

Panel Panel name String Explore_HT

Block Name of  the block the sample was run on String 1, 2, 3, 4, 5, 6, 7, or 8

Count The total number of counts Integer  Greater than or equal to 1

ExtNPX Intermediate value between count and NPX: log2 of the 
ratio between data-point Count value and the count for 
the Extension Control assay for the same sample.

Double -1.94701

NPX NPX value Double

Normalization Type of normalization used in project String  Plate control, Intensity or 
EXCLUDED

PCNormalizedNPX NPX value displayed if plate control normalization has 
been chosen.

Double 1.735509

AssayQC Overall QC status for an assay String NA, PASS, WARN

SampleQC Overall QC status for a sample in a block String NA, PASS, WARN, FAIL

ExploreVersion Software version of the module in NPX Explore HT & 3072 
used for panel calculations and normalization

String

Part 3: Operation 
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13.3 Extended NPX file
The Extended NPX file is a Parquet-file generated by the Explore CLI and NPX Explore HT & 3072. 

The Extended NPX file contains all the columns in the NPX file, plus the set of additional columns listed below. 

• IntraCV 

• InterCV 

• SampleBlockQCWarn 

• SampleBlockQCFail 

• BlockQCFail 

• AssayQCWarn 

For more information, refer to the Olink® Explore CLI Technical Information.

13.4 Analysis Report
The analysis report is a pdf-file that can be generated from NPX Explore HT & 3072 and CLI. 

The analysis report summarizes the quality analysis of the project. It contains basic information and descriptions of the 
project. It also contains a summary of the Quality control including sample passed QC.

The Analysis Report contains the following:

• Project information

 – Sample matrix

 – Project specific comments

• Quality control

 – QC summary

 – Data output

 – Software version information

• Appendix - A table including the following columns

 – Olink Panel

 – Block

 – UniProt

 – Assay Olink ID

Part 3: Operation 
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Part 4: Quality Control

14. Overview
Olink Explore contains a built-in quality control system using three internal and three external controls, which enables full 
control over the technical performance of assays and samples. It is fully automated and is performed directly on Counts 

and therefore can detect severe technical errors.

If the QC is not accurate, please contact support@olink.com.

14.1 Internal controls
Three internal controls are spiked into every sample for each block. The internal controls are designed to monitor the 
quality of assay performance, as well as the quality of individual samples:

Amplification control
Extension control

Incubation control

IMMUNO REACTION EXTENSION/LIBRARY AMPLIFICATION DETECTION
C T G A

C T T
G

GA
A A

A

A
T

C

T

T

C T T
G

GA
A A

A

C
T

G A A T
C

T

T

Figure 1. Internal quality controls

Incubation Control (Immuno Control): The Immuno Control is a non-human antigen measured with PEA. This control is 
included in the immuno reaction (incubation) and monitors potential technical variation in all three steps of the reaction. 

Extension Control: The Extension Control is composed of an antibody coupled to a unique pair of DNA-tags. These 
DNA-tags are always in proximity, so that this control is expected to give a constant signal independently of the immuno 
reaction. This control monitors variation in the extension and amplification step. 

Amplification Control: The Amplification Control is a complete double stranded DNA amplicon which does not require 
any proximity binding or extension step to generate a signal. This control monitors the amplification/sample indexing step.

The Extension Control is used to calculate the NPX, refer to 15.4 Normalization, and the other two are used in Quality 
Control.
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Part 4: Quality Control 
15. The QC overview

15. The QC workflow
Three internal controls are added to each sample to monitor the quality of assay performance, as well as the quality of 
individual samples:

• Incubation Control

• Extension Control

• Amplification Control

The Extension Control is used to calculate the NPX, refer to 15.4 Normalization, and the other two are used in Quality 
Control (described below).

Output:
Count

Output:
Count, ExtNPX, 

NPX_pc, NPX_int

FAIL

PASS/WARN

Systematic
Effects

Row/column
effect

Gradient
pattern

Plate QC

Sample QC

Block QC

Assay QC

Normalization

Plate 
Control

Intensity
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Part 4: Quality Control 
15. The QC overview

15.1 Plate QC
The QC is performed directly on Counts, on one block per 96 samples. The Plate QC are divided into three parts:

15.1.1 Sample QC
Samples and external controls that fail Sample QC will not be considered for additional QC steps and not normalized. Only 
counts will be reported for those.

1. Low total number of counts per sample per block 
Too low total counts for a sample might indicate that the sample is missing or the index was not added to the sample. 
Each sample and external control should have a minimum number of counts in a block, otherwise they fail.

2. Low number of counts of internal controls per block 
Low counts in any of the internal controls might indicate a technical error in the workflow for the corresponding 
sample, for example a missing internal control. 

 – Each external control should have a minimum number of counts for each of the internal controls, otherwise they 
fail. 

 – Each sample should have a minimum number of counts for each of the internal controls, otherwise they fail or 
get a warning.

3. Deviation of counts in Plate Controls 
Deviation of internal control's counts from the expected ranges in Plate Controls might indicate different technical 
errors.

 – A Plate Control fails if the fraction of counts of all internal controls to total counts in logarithmic scale, deviates 
positively or negatively from the reference values. The reference ranges are block specific and kit lot related.

4. Unexpected signal in Negative Controls 
Detection of high number of counts for many assays, relative to the counts of internal controls, in any Negative 
Controls might indicate that signals are from other sample types or not from pure buffer.

 – A Negative Control fails if many assays get higher number of counts relative to the counts of internal controls.

15.1.2 Block QC
Block QC is to quality control whether a block-plate is affected by technical errors This step is performed only on the Plate 
and Negative Controls that pass Sample QC. A failed block is recommended to be rerun. 

1. Based on Plate Controls:

 – A block-plate fails if <50% of Plate Controls pass the Sample QC (a minimum of 3 Plate Controls is required to 
pass the block-plate).

2. Based on Negative Controls:

 – A block-plate fails if none of the Negative Control pass the Sample QC.

15.1.3 Assay QC
Detection of high number of counts for any assay, relative to the internal controls, in any of the Negative Controls is 
considered as unexpected signal. This step is performed on Negative Controls that pass Sample QC. 

• An assay gets a QC warning if it gets high number of counts relative to the counts in internal controls in all Negative 
Controls.

For acceptance criteria for Sample QC, Block QC and Assay QC, refer to table in 10. Perform quality controls. 
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15.2 Systematic effect detection
Systematic effects are defined as a systematic  pattern on a plate caused by a deviation in the workflow such as 
instrument failure or human error. A pattern corresponds to a particular type of failure. Detection of systematic effects is 
complementary to the Plate QC and is performed on NPX. All samples and data-points (passed, failed, and warned) are 
included in the computation. 

Systematic effects are categorized into patterns that impact the full plate or impacting a row or/and column. To detect the 
patterns, three main criteria are considered: 

• The frequency of assays representing the effect

• The intensity of the effect on NPX deviation

• Number of samples showing the effect  

A pattern is detected per assay/block/plate unit. If enough assays (internal controls are not included) are affected, the 
block will get a systematic effects warning corresponding to that effect in NPX Explore HT & 3072 Software (Quality 
Control Summary tab). Systematic effects may be due to either non-randomized plate design or technical errors and 
should be investigated further when warned. 

15.2.1 Types of systematic effects
• Row

• Column

• Four_column

• Alternating_column

• Row_gradient

• Column_Gradient

• Diagonal_Gradient

15.3 Summary notes for exported data
• Data related to all assays, including the internal controls, will be presented in the output NPX file. 

• Data related to all samples, including the external controls, will be presented in the output NPX file.

• Data related to any failed sample or block that do not pass QC criteria will not be normalized and therefore no NPX will 
be computed. Counts are reported for the failed data-points in the NPX file. 

• Any data-points with a QC warning should be used with caution. 

For any more information about Plate QC and systematic effects, please contact support@olink.com.
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15.4 Normalization
The two between-plate-normalization methods are called Plate Control (PC) normalization and intensity normalization. 
They both adjust each assay per plate to a median, but they differ in how these medians are calculated. An important 
concept when selecting normalization procedure is randomization, which in this context applies to the sample placement 
across the plates. For details, refer to Randomization FAQ on the Olink website.

Plate Control normalization should be selected for all Explore HT project (projects with single or multiple plates, projects 
where complete randomization of samples can not be guaranteed, etc). Plate Control normalized NPX will by default be 
reported in the output NPX file. Contact support for study design assistance and choosing the appropriate normalization 
type. 

15.4.1 Counts
The Olink Explore system’s raw data output is counts, where each combination of assay and sample is given an integer 
value based on number of copies detected. These raw data counts are converted into NPX values for use in the continued 
analysis.

15.4.2 Converting counts to NPX
The Olink Explore system’s raw data output is counts, where each combination of assay and sample is given an integer 
value based on number of copies detected. These raw data counts are converted into NPX values for use in the continued 
analysis.

NPX generation 
The NPX values are calculated in two main steps, followed by an optional additional step between-plate-normalization. 
First, the assay counts of a sample are divided with the Extension Control for that sample and block. The resulting scale 
has increasing values with increasing concentration for each assay. A log2 transformation is applied and the final step is 
subtracting the median of the Plate Controls. The optional additional step is intensity normalization which sets the median 
level of all assays to the same value for all plates. The different steps are described below.

Steps in the NPX generation described in equation form, where i refers to a specific assay, j refers to a sample, and ExtNPX 
defines an extension normalized NPX value.

1. ExtNPX_i, j = log2(counts(sample_jAssay_i)/counts (ExtCtrl_j))

a. Relate counts to known standard (Extension Control).

b. For all assays and all samples, including Negative Controls, Plate Controls, and Sample Controls.

c. Log2 transformation gives more normally distributed data.

2. NPX_i, j = ExtNPX_i, j-median (ExtNPX(Plate Controls_i))

a. Perform plate standardization.

b. For all assays and per plate of samples.

3. NPX_Intnorm_i,j = (ExtNPX_i,j – plate median(ExtNPX_i))

a. Between plate normalization.

b. For each assay, for all plates in project.

Part 4: Quality Control 
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15.4.3 CV calculation
To evaluate the reproducibility and repeatability of data related to each plate in the project, and to assess the within- and 
between-plate variation in the project, two types of CV are computed for each of the pre-selected assays: within plate 
(intra CV) and between plates (inter CV) in Sample Controls. For the inter CV calculation, the mean of Sample Controls is 
used to represent the plate before CV calculation.

In each block, pre-selected assays with good performance in Olink Sample Controls are used so that any deviating CV 
actually indicates a potential technical issue within the workflow. The CV is calculated for NPX of those selected assays (i), 
using the assumption of a log-normal distribution, in Sample Controls using the formula below. The CV is part of the UI 
assessing run quality, and is presented in a CV Table showing average CV:s over the blocks

CVi = 100 √( e
Slni2 - 1), where Slni = ln(2) × SDisk

Part 4: Quality Control 
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Part 5: Troubleshooting

16. Troubleshooting
This chapter includes a trouble shooting guide, describing QC issues, affected level (sample, block, plate) and possible root 
causes for some potential non-expected results. Reruns are not recommended except for the projects that have failed to 
pass formal QC. Please contact support@olink.com for further investigations and receiving appropriate guidance for any 
of these cases.

QC issue Affected  
samples/blocks/Sample plates

Possible cause 

Plate Controls and/or samples fail

Failed Plate Controls:

Deviation from reference values (±)

Multiple blocks (1-4 or 5-8) 

Both sample plates plates 

 – Dilution plates or Sample Plate 
swapped positions on Mosquito 

 – Wrong dilution protocol was used

Plate Controls fail:

Deviation from reference values

(Inc & Ext -, AMP +)

(Inc, Ext & AMP -)

Multi blocks in both Sample plates Poor PCR enzyme efficiency due 
to not adding enough Enzyme A or 
Enzyme B

Plate Controls fail:

Deviation from reference values 

(Inc -, Amp & Ext +)
 – Low counts for Incubation Controls 
 – Low counts for assays
 – High counts for Amplification and External 
Controls 

The same single block in both Sample 
Plates (e.g. Block 2 in SP1 and SP2)

1A: Forward probe was not added to 
the incubation reagent mix

1B: Not enough incubation solution 
was added while preparing the 
reagent mix

The same two blocks in both Sample 
Plates (e.g. Blocks 2 and 5 in SP1 and 
SP2)

2A: Forward probes were mixed up 
for the two blocks when preparing 
incubation mix (wrong pair of probes)

2B: Not enough incubation solution 
was added while preparing the 
reagent mix

Samples and/or external Controls fail:

Too low counts

1. One or multi samples in a block

One or both Sample Plates.

1. Incubation reagents mix or index 
not added properly due to Mosquito 
pipetting error

2. All or multi samples in multi blocks 

(Likely blocks 1-4)

Both Sample Plates.

2. Poor sequencing if %PF is low

Samples and Plate Controls fail:

Too low counts
 – Low counts for assays
 – Low counts for all internal controls

1. One same block in both Sample 
plates (e.g. Block 2 in SP1 and SP2)

1. Reverse probe was not added into 
incubation reagent mix

2. The same two blocks in both 
Sample plates (e.g. Blocks 2 and 5 in 
SP1 and SP2)

2. Reverse probes were mixed up 
for the two blocks when preparing 
incubation mix (wrong pair of 
probes). Amplification Control might 
have some counts.
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Negative Control fail

Negative Controls fail 

(Plate Controls might fail too)

1. Multi blocks in one Sample Plate 

(likely blocks 5-8)

1A. The plate layout does not match 
with the uploaded run.

1B. NCs related to one of the Sample 
Plates were pipette into wrong wells 
on Sample Source Plates.

1C. Negative Controls are 
contaminated

2. The same multi blocks in both 
Sample Plates (blocks 1-4 or 5-8)

2A. Sample Source Plates was rotated 
in the workflow

2B. Samples added instead of 
Negative Controls in Sample Source 
Plates

2C. Index plate A and B were swapped 
positions on mosquito between the 
two stages of adding indexes

2D. Negative Controls are 
contaminated

Systematic effect

Alternating column effect:

NPX value deviates in every other column 

One or multiple blocks in one or both 
Sample Plates

Mosquito pipetting error while 
dispensing reagent mix into 
incubation plate

Every 4 columns effect:

NPX values deviate between every 4 columns 

Two blocks in both Sample Plates  – Dragonfly faulty syringe during 
dispensation of PCR mix

 – Not well vortex of PCR mix

Row effect:

NPX values deviate between samples in one 
row and samples in all other rows 

Same row in the same block in both 
Sample Plate

 – EpMotion pipetting error when 
pooling the samples 

 – Human error missing one well 
during pooling step 
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Gradient patterns 
(row/column/diagonal wised):

NPX Values deviate gradually in samples 
across the plate in row, column, or diagonal 
pattern 

One or multi blocks in both Sample 
Plates

 – Not well vortex of reagent mix/
plates

 – Not well adjusted/calibrated 
instruments 
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17. Revision history
Version Software 

version
Date Description

2.3 2.3 2024-02-26 5.1.2 added.

7 updated with new figures and information about NPX Explore 
3072 projects and according to new views.

9.1 added.

10 table updated med acceptance criteria for Olink Explore 384 
panels, and note added.

Name change of software and manual.

2.2 v2.2 2023-12-01 7.3 added.

13.1.2 added.

Version number updated to match the software version 
(v.1.1÷v2.1 does not exist)

1.1 v2.1 2023-10-09 7.2, 7.7, and 7.10 supplementary information added. 

9.2 supplementary information added. 

11.2 supplementary information added. 

13.4 supplementary information added. 

15.2.1 new.

1.0 v2.0 2023-08-14 New

1325, v2.3, 2024-02-26
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